summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorZbyszek Jędrzejewski-Szmek <zbyszek@in.waw.pl>2012-07-18 10:06:18 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2012-07-21 07:55:36 +0200
commit2fd8b540c939d1dfdea3f42bd04a378035b3e070 (patch)
treeaa922876b5a4fd71f7af7fbb447ad96a3707e2c6 /autogen.sh
parenta804b788a89a881260c4d4c7eccc1677f27c54af (diff)
build-sys: fail early in autogen.sh
When intltoolize is not installed, autogen.sh runs without error, but configure.ac is borked. ./configure: line 12001: syntax error near unexpected token `0.40.0' ./configure: line 12001: `IT_PROG_INTLTOOL(0.40.0)'
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh2
1 files changed, 2 insertions, 0 deletions
diff --git a/autogen.sh b/autogen.sh
index f9ad5f0a1..bec43fad7 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -15,6 +15,8 @@
# You should have received a copy of the GNU Lesser General Public License
# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+set -e
+
if [ -f .git/hooks/pre-commit.sample -a ! -f .git/hooks/pre-commit ] ; then
cp -p .git/hooks/pre-commit.sample .git/hooks/pre-commit && \
chmod +x .git/hooks/pre-commit && \