summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-08-19 22:27:38 +0200
committerAndy Wingo <wingo@pobox.com>2015-08-19 22:35:57 +0200
commit4ef8c8a39392c25ae3fc5ac59583fb3361cf5663 (patch)
tree17540783cc9b64d62d693c8d44ac82a24e7763fd /autogen.sh
parente9c3ed523c0134548a66cfd6677eb4c034439796 (diff)
Play better with non-FHS distros
* Makefile.am: Remove rootprefix, rootbindir, and rootlibexecdir. udevrulesdir is substed from configure.ac. Adapt distcheck. * autogen.sh: Make more normal. * configure.ac: Add --with-udevrulesdir. Remove --with-rootprefix. Detect bin dir for udev.
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh51
1 files changed, 0 insertions, 51 deletions
diff --git a/autogen.sh b/autogen.sh
index 7b62449be..3997db30e 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -39,54 +39,3 @@ fi
intltoolize --force --automake
autoreconf --force --install --symlink
-
-libdir() {
- echo $(cd "$1/$(gcc -print-multi-os-directory)"; pwd)
-}
-
-args="\
---sysconfdir=/etc \
---localstatedir=/var \
---libdir=$(libdir /usr/lib) \
-$gtkdocargs"
-
-if [ -f "$topdir/.config.args" ]; then
- args="$args $(cat $topdir/.config.args)"
-fi
-
-if [ ! -L /bin ]; then
-args="$args \
---with-rootprefix= \
---with-rootlibdir=$(libdir /lib) \
-"
-fi
-
-cd $oldpwd
-
-if [ "x$1" = "xc" ]; then
- $topdir/configure CFLAGS='-g -O0 -ftrapv' --enable-compat-libs --enable-kdbus $args
- make clean
-elif [ "x$1" = "xt" ]; then
- $topdir/configure CFLAGS='-g -O0 -ftrapv' --enable-compat-libs --enable-kdbus --enable-terminal $args
- make clean
-elif [ "x$1" = "xg" ]; then
- $topdir/configure CFLAGS='-g -Og -ftrapv' --enable-compat-libs --enable-kdbus $args
- make clean
-elif [ "x$1" = "xa" ]; then
- $topdir/configure CFLAGS='-g -O0 -Wsuggest-attribute=pure -Wsuggest-attribute=const -ftrapv' --enable-compat-libs --enable-kdbus $args
- make clean
-elif [ "x$1" = "xl" ]; then
- $topdir/configure CC=clang CFLAGS='-g -O0 -ftrapv' --enable-compat-libs --enable-kdbus $args
- make clean
-elif [ "x$1" = "xs" ]; then
- scan-build $topdir/configure CFLAGS='-std=gnu99 -g -O0 -ftrapv' --enable-kdbus $args
- scan-build make
-else
- echo
- echo "----------------------------------------------------------------"
- echo "Initialized build system. For a common configuration please run:"
- echo "----------------------------------------------------------------"
- echo
- echo "$topdir/configure CFLAGS='-g -O0 -ftrapv' --enable-compat-libs --enable-kdbus $args"
- echo
-fi