summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTollef Fog Heen <tfheen@err.no>2010-05-16 11:03:34 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-16 18:18:02 +0200
commit136337ff74f05be3d42a769d9f0cb99716c5c40f (patch)
tree79c640f04ec8e20726e44a748e86b2533636957d /configure.ac
parentbf024b022d9f53d2bb8d26107b4878cede3167b7 (diff)
build-sys: support setting path and service names from configure
Allow passing --with switches for SysV init path, SysV rcN.d path, DBus and syslog service names. Also bail out if those are not passed and distro is other
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 32 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f4423d343..1c97899dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,16 +200,44 @@ case $with_distro in
AC_DEFINE(TARGET_SLACKWARE, [], [Target is Slackware])
;;
other)
- SYSTEM_SYSVINIT_PATH=/fix/the/configure/script
- SYSTEM_SYSVRCND_PATH=/fix/the/configure/script
- special_dbus_service=fix-the-configure-script.service
- special_syslog_service=fix-the-configure-script.service
+ AS_IF([test "x$with_sysvinit_path" = "x"],
+ [AC_MSG_ERROR([With --distro=none, you must pass --with-sysvinit-path to configure])])
+ AS_IF([test "x$with_sysvrcd_path" = "x"],
+ [AC_MSG_ERROR([With --distro=none, you must pass --with-sysvrcd-path to configure])])
+ AS_IF([test "x$with_dbus_service" = "x"],
+ [AC_MSG_ERROR([With --distro=none, you must pass --with-dbus-service to configure])])
+ AS_IF([test "x$with_syslog_service" = "x"],
+ [AC_MSG_ERROR([With --distro=none, you must pass --with-syslog-service to configure])])
;;
*)
AC_MSG_ERROR([Your distribution (${with_distro}) is not yet supported, SysV init scripts could not be found! (patches welcome); you can specify --with-distro=other to skip this check])
;;
esac
+AC_ARG_WITH([sysvinit-path],
+ [AS_HELP_STRING([--with-sysvinit-path=PATH],
+ [Specify the path to where the SysV init scripts are located @<:@default=based on distro@:>@])],
+ [SYSTEM_SYSVINIT_PATH="$withval"],
+ [])
+
+AC_ARG_WITH([sysvrcd-path],
+ [AS_HELP_STRING([--with-sysvrcd-path=PATH],
+ [Specify the path to the base directory for the SysV rcN.d directories @<:@default=based on distro@:>@])],
+ [SYSTEM_SYSVRCND_PATH="$withval"],
+ [])
+
+AC_ARG_WITH([dbus-service],
+ [AS_HELP_STRING([--with-dbus-service=PATH],
+ [Specify the name of the special DBus service @<:@default=based on distro@:>@])],
+ [special_dbus_service="$withval"],
+ [])
+
+AC_ARG_WITH([syslog-service],
+ [AS_HELP_STRING([--with-syslog-service=PATH],
+ [Specify the name of the special syslog service @<:@default=based on distro@:>@])],
+ [special_syslog_service="$withval"],
+ [])
+
AC_SUBST(SYSTEM_SYSVINIT_PATH)
AC_SUBST(SYSTEM_SYSVRCND_PATH)