summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFilipe Brandenburger <filbranden@google.com>2014-06-24 23:06:45 -0700
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-26 01:41:05 -0400
commit2f96919bcdd0978164c801b21e053fb3b31e8bac (patch)
tree46740051c24a81818cfaf810aadb33857231ff47 /configure.ac
parent908f8b9cbb9432e8a8af39d528e150f1fe11b50e (diff)
build-sys: add explicit support for --disable-nls
In particular, disable intltool when --disable-nls is passed to configure. Tested: Built it on a host without intltool or gettext. $ ./configure --disable-nls --disable-polkit $ make
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bb6018f87..31879d3fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,7 +49,17 @@ AS_IF([test "x$enable_static" = "xyes"], [AC_MSG_ERROR([--enable-static is not s
AS_IF([test "x$enable_largefile" = "xno"], [AC_MSG_ERROR([--disable-largefile is not supported by systemd])])
# i18n stuff for the PolicyKit policy files
+AM_NLS
+AS_IF([test x"$enable_nls" != xno], [
+ # intltoolize greps for '^(AC|IT)_PROG_INTLTOOL', so it needs to be on its own line
IT_PROG_INTLTOOL([0.40.0])
+])
+
+AS_IF([test -z "$INTLTOOL_POLICY_RULE"], [
+ # If intltool is not available, provide a dummy rule to fail generation of %.policy files with a meaningful error message
+ INTLTOOL_POLICY_RULE='%.policy: %.policy.in ; @echo " ITMRG " $@ && echo "*** intltool support required to build target $@" && false'
+ AC_SUBST(INTLTOOL_POLICY_RULE)
+])
GETTEXT_PACKAGE=systemd
AC_SUBST(GETTEXT_PACKAGE)