summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-02-28 19:53:42 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-02-28 20:05:12 -0500
commit37d3ab1b7e114f0fb6dfb2e7273569b42794b76a (patch)
treeb69f73466e4719b6f02d4b30fcaa42ec43f1c40d /configure.ac
parent54c31a79f72ff57ac8eba089acacc4ab482b745d (diff)
parent7f41820b07ccb8a6da5552c466818fcce3d085bf (diff)
Merge branch 'python-systemd-reader'
* python-systemd-reader: python-systemd: rename Journal to Reader build-sys: upload python documentation to freedesktop.org systemd-python: add Journal class for reading journal python: build html docs using sphinx journalct: also print Python code in --new-id python: utilize uuid.UUID in logging python: add systemd.id128 module ... and 34 other commits In short: python module systemd.id128 is added, and existing systemd.journal gains a new class systemd.journal.Reader, which can be used to iterate over journal entries. Documentation is provided, and accessible under e.g. pydoc3 systemd.journal.Reader or firefox http://www.freedesktop.org/software/systemd/man/python-systemd/
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b7a587c66..ea9fafe2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,6 +176,7 @@ AS_IF([test "x$with_python" != "xno"], [
PYTHON_LIBS="`$PYTHON_CONFIG --ldflags`"
AC_SUBST(PYTHON_CFLAGS)
AC_SUBST(PYTHON_LIBS)
+ AC_PATH_PROGS(SPHINX_BUILD, sphinx-build-${PYTHON_VERSION} sphinx-build)
])
])
AM_CONDITIONAL([HAVE_PYTHON_DEVEL], [test "$have_python_devel" = "yes"])