summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-02-06 21:11:27 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-02-13 01:05:28 -0500
commit6fc00209d5906bd14d54af4a6ac2961dd9731f72 (patch)
tree40427d4a8cce4ccf9083699a88ac0e99be19779d /configure.ac
parent6bb25a058227d89fbbeba6c12873e6f83da5cf94 (diff)
build-sys: disable tests in po/, docs/ with separate build dir
Both gtk-doc and intltoolize have problems with VPATH builds. "Creatively" disable tests when configuring from outside the source directory. This more-or-less reverts 9795da43c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 56694ff22..4e36dc3dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -821,6 +821,13 @@ AS_IF([test "x${enable_split_usr}" = "xyes"], [
AC_DEFINE(HAVE_SPLIT_USR, 1, [Define if /bin, /sbin aren't symlinks into /usr])
])
+# Work around intltoolize and gtk-doc problems in VPATH builds
+AM_CONDITIONAL([ENABLE_GTK_DOC_TESTS], [test "x$0" = "x./configure"],
+ [Define to do gtk-doc tests])
+AS_IF([test "x$0" != "x./configure"], [
+ AC_SUBST([INTLTOOL_UPDATE], [/bin/true])
+])
+
AC_SUBST([dbuspolicydir], [$with_dbuspolicydir])
AC_SUBST([dbussessionservicedir], [$with_dbussessionservicedir])
AC_SUBST([dbussystemservicedir], [$with_dbussystemservicedir])