summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-07-19 11:55:18 +0200
committerSven Eden <yamakuzure@gmx.net>2017-07-20 08:29:14 +0200
commit7873fa750d7d4310396e69df12b53e07e4e81249 (patch)
treec1175674af487fa3d492b0a78ef556b48ffc5c9d /configure.ac
parenta97a730270418e53e9400de5dce7b07c7dacd19a (diff)
Prep v233.3: Add all possible coverage tests for elogind
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 281570e45..aa3cf86bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -764,9 +764,10 @@ AS_IF([test "x$0" != "x./configure"], [
])
AC_ARG_ENABLE(tests,
- [AS_HELP_STRING([--disable-tests], [disable tests, or enable extra tests with =unsafe])],
+ [AC_HELP_STRING([--disable-tests], [disable tests, or enable extra tests with =unsafe])],
enable_tests=$enableval, enable_tests=yes)
-AM_CONDITIONAL(ENABLE_TESTS, [test x$enable_tests = xyes])
+AM_CONDITIONAL(ENABLE_TESTS, [test x$enable_tests = xyes -o x$enable_tests = xunsafe])
+AM_CONDITIONAL(ENABLE_UNSAFE_TESTS, [test x$enable_tests = xunsafe])
AC_ARG_ENABLE(debug,
[AC_HELP_STRING([--enable-debug@<:@=LIST@:>@], [enable extra debugging (elogind,hashmap,mmap-cache)])],