summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-02-20 05:57:50 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:23:13 +0100
commit89e750e26ce052aec7d38306328a0f52c90c5489 (patch)
tree74d3e4276e7b1c69e85ddb193f4d003c2403f09a /configure.ac
parent0bf638bafb228d8eaf429e55c0609a3802c37c5b (diff)
Add --enable-debug=elogind configure option and fix cgroup path
a) Add some debugging messages to track what's going on with eloginds cgroup handling. b) Do not create a cgroup path "/elogind" if our cgroup root is already "/elogind".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5da0e12ca..dc889a7f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -664,14 +664,17 @@ AC_ARG_ENABLE(tests,
AM_CONDITIONAL(ENABLE_TESTS, [test x$enable_tests = xyes])
AC_ARG_ENABLE(debug,
- [AC_HELP_STRING([--enable-debug@<:@=LIST@:>@], [enable extra debugging (hashmap,mmap-cache)])],
+ [AC_HELP_STRING([--enable-debug@<:@=LIST@:>@], [enable extra debugging (elogind,hashmap,mmap-cache)])],
[if test "x$enableval" = "xyes"; then
- enableval="hashmap,mmap-cache"
+ enableval="elogind,hashmap,mmap-cache"
fi
saved_ifs="$IFS"
IFS="$IFS$PATH_SEPARATOR,"
for name in $enableval; do
case $name in
+ elogind)
+ enable_debug_elogind=yes
+ ;;
hashmap)
enable_debug_hashmap=yes
;;
@@ -683,6 +686,10 @@ AC_ARG_ENABLE(debug,
IFS="$saved_ifs"],[])
enable_debug=""
+AS_IF([test x$enable_debug_elogind = xyes], [
+ AC_DEFINE(ENABLE_DEBUG_ELOGIND, 1, [Define if elogind debugging is to be enabled])
+ enable_debug="elogind $enable_debug"
+])
AS_IF([test x$enable_debug_hashmap = xyes], [
AC_DEFINE(ENABLE_DEBUG_HASHMAP, 1, [Define if hashmap debugging is to be enabled])
enable_debug="hashmap $enable_debug"