summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-01-20 04:58:34 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:23:02 +0100
commita7658a3431d6fce7c503c7a371c9fd91f2cd748f (patch)
treebf5e6dda7d21599e07b4a7cd9dea4c364f766647 /configure.ac
parentbec1345672f400faca26c4d231c0b6a7360801ed (diff)
Remove librt dependency.
The only function still using librt was src/shared/clean-ipc.c::clean_posix_mq(). But that function is not really needed, because elogind does not call mq_open() anywhere, or any other mqueue related functions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 66a5e3e9a..351dda27e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,8 +287,8 @@ AC_CHECK_HEADERS([linux/btrfs.h], [], [])
AC_CHECK_HEADERS([linux/memfd.h], [], [])
# unconditionally pull-in librt with old glibc versions
-AC_SEARCH_LIBS([clock_gettime], [rt], [], [])
-AC_SEARCH_LIBS([mq_unlink], [rt], [], [])
+dnl AC_SEARCH_LIBS([clock_gettime], [rt], [], [])
+dnl AC_SEARCH_LIBS([mq_unlink], [rt], [], [])
AC_ARG_WITH([libcap],
AS_HELP_STRING([--with-libcap=DIR], [Prefix for libcap]),