summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-19 15:43:41 +0200
committerAndy Wingo <wingo@pobox.com>2015-04-19 15:43:41 +0200
commitaa3a6439d1f398ac56127057bbf75b6e4536721f (patch)
tree505383bc06eec4a452495fbbb62ca774024487af /configure.ac
parentc3eb2a0d436cb84248f244353b28841e42e59abd (diff)
Remove elfutils checks
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 0 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index 0632c51c6..183240554 100644
--- a/configure.ac
+++ b/configure.ac
@@ -486,52 +486,6 @@ fi
AM_CONDITIONAL([HAVE_SMACK], [test "x$have_smack" = "xyes"])
# ------------------------------------------------------------------------------
-AC_ARG_ENABLE([elfutils],
- AS_HELP_STRING([--disable-elfutils],[Disable optional ELFUTILS support]),
- [case "${enableval}" in
- yes) have_elfutils=yes ;;
- no) have_elfutils=no ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --disable-elfutils) ;;
- esac],
- [have_elfutils=auto])
-
-if test "x${have_elfutils}" != xno ; then
- AC_CHECK_HEADERS(
- [elfutils/libdwfl.h],
- [],
- [if test "x$have_elfutils" = xyes ; then
- AC_MSG_ERROR([*** ELFUTILS headers not found.])
- fi])
-
- AC_CHECK_LIB(
- [dw],
- [dwfl_begin],
- [],
- [if test "x$have_elfutils" = xyes ; then
- AC_MSG_ERROR([*** ELFUTILS libs not found.])
- fi])
-
- AC_CHECK_LIB(
- [dw],
- [dwfl_core_file_attach],
- [have_elfutils=yes],
- [if test "x$have_elfutils" = xyes ; then
- AC_MSG_ERROR([*** ELFUTILS >= 158 is required.])
- fi])
-
- if test "x$have_elfutils" = xyes ; then
- ELFUTILS_LIBS="-lelf -ldw"
- AC_DEFINE(HAVE_ELFUTILS, 1, [ELFUTILS available])
- else
- have_elfutils=no
- fi
-else
- ELFUTILS_LIBS=
-fi
-AC_SUBST(ELFUTILS_LIBS)
-AM_CONDITIONAL(HAVE_ELFUTILS, [test "$have_elfutils" = "yes"])
-
-# ------------------------------------------------------------------------------
have_libcryptsetup=no
AC_ARG_ENABLE(libcryptsetup, AS_HELP_STRING([--disable-libcryptsetup], [disable libcryptsetup tools]))
if test "x$enable_libcryptsetup" != "xno"; then
@@ -1155,7 +1109,6 @@ AC_MSG_RESULT([
GNUTLS: ${have_gnutls}
libcurl: ${have_libcurl}
libidn: ${have_libidn}
- ELFUTILS: ${have_elfutils}
binfmt: ${have_binfmt}
vconsole: ${have_vconsole}
bootchart: ${have_bootchart}