summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-03-30 23:08:02 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-07-15 22:23:49 -0400
commitad95fd1d2b9c6344864857c2ba7634fd87753f8e (patch)
treee7aae19861980ba134efa9da2189dd14d42631f6 /configure.ac
parenta3152e7655231b94fa7b9582906fb86ab00b9c99 (diff)
journal-remote: add units and read certs from default locations
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6e972e361..94aacc933 100644
--- a/configure.ac
+++ b/configure.ac
@@ -498,6 +498,14 @@ AC_ARG_WITH([debug-tty],
AC_SUBST(DEBUGTTY)
+AC_ARG_WITH([certificate-root],
+ AS_HELP_STRING([--with-certificate-root=PATH],
+ [Specify the prefix for TLS certificates [/etc/ssl]]),
+ [CERTIFICATEROOT="$withval"],
+ [CERTIFICATEROOT="/etc/ssl"])
+
+AC_SUBST(CERTIFICATEROOT)
+
# ------------------------------------------------------------------------------
have_xz=no
AC_ARG_ENABLE(xz, AS_HELP_STRING([--disable-xz], [Disable optional XZ support]))
@@ -1377,6 +1385,7 @@ AC_MSG_RESULT([
TTY GID: ${TTY_GID}
Maximum System UID: ${SYSTEM_UID_MAX}
Maximum System GID: ${SYSTEM_GID_MAX}
+ Certificate root: ${CERTIFICATEROOT}
CFLAGS: ${OUR_CFLAGS} ${CFLAGS}
CPPFLAGS: ${OUR_CPPFLAGS} ${CPPFLAGS}