summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-06-08 08:49:12 +0200
committerSven Eden <yamakuzure@gmx.net>2017-06-16 10:12:58 +0200
commitb4f4684f3a95c915491cd7845911ecdf2622b2c2 (patch)
tree75d5cf09c96acae48f9578294b587afef1391706 /configure.ac
parent3e00151fe64164d2a5f2e231120cb4247ec1794f (diff)
Prep v230: Add utmp support to make wall message to work properly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a327e2c39..8450bbcd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -421,6 +421,16 @@ AC_ARG_WITH([udevbindir],
AC_SUBST([udevbindir], [$with_udevbindir])
# ------------------------------------------------------------------------------
+have_utmp=yes
+AC_ARG_ENABLE([utmp], AS_HELP_STRING([--disable-utmp], [disable utmp/wtmp log handling]),
+ AS_CASE("x${enableval}",
+ [xyes], [have_utmp=yes],
+ [xno], [have_utmp=no],
+ AC_MSG_ERROR(bad value ${enableval} for --enable-utmp)))
+AS_IF([test "x$have_utmp" = "xyes"], [AC_DEFINE(HAVE_UTMP, 1, [Define if utmp/wtmp support is enabled])])
+AM_CONDITIONAL([HAVE_UTMP], [test "x$have_utmp" = "xyes"])
+
+# ------------------------------------------------------------------------------
have_coverage=no
AC_ARG_ENABLE(coverage, AS_HELP_STRING([--enable-coverage], [enable test coverage]))
if test "x$enable_coverage" = "xyes" ; then
@@ -783,6 +793,7 @@ AC_MSG_RESULT([
man pages: ${have_manpages}
test coverage: ${have_coverage}
Split /usr: ${enable_split_usr}
+ utmp/wtmp support: ${have_utmp}
Link time optimization: ${have_lto}
extra debugging: ${enable_debug}
cgroup controller: ${with_cgroupctrl}