summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-02-13 23:07:59 +0100
committerLennart Poettering <lennart@poettering.net>2013-02-13 23:08:25 +0100
commitb872e9a05939bc3e0ac95a042592506a7488dd6f (patch)
tree53a2f851a45ab77af7c1893f50a1d706f37584f5 /configure.ac
parent46ba8aae2b82bc5c87ba347e6bf914ecd5e9d51e (diff)
build-sys: make EFI support build-time optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 228f6969f..834b12314 100644
--- a/configure.ac
+++ b/configure.ac
@@ -636,6 +636,15 @@ fi
AM_CONDITIONAL(ENABLE_POLKIT, [test "x$have_polkit" = "xyes"])
# ------------------------------------------------------------------------------
+have_efi=no
+AC_ARG_ENABLE(efi, AS_HELP_STRING([--disable-efi], [disable EFI support]))
+if test "x$enable_efi" != "xno"; then
+ AC_DEFINE(ENABLE_EFI, 1, [Define if EFI support is to be enabled])
+ have_efi=yes
+fi
+AM_CONDITIONAL(ENABLE_EFI, [test "x$have_efi" = "xyes"])
+
+# ------------------------------------------------------------------------------
AC_ARG_WITH(rc-local-script-path-start,
AS_HELP_STRING([--with-rc-local-script-path-start=PATH],
[Path to /etc/rc.local]),
@@ -882,6 +891,7 @@ AC_MSG_RESULT([
localed: ${have_localed}
coredump: ${have_coredump}
polkit: ${have_polkit}
+ efi: ${have_efi}
kmod: ${have_kmod}
blkid: ${have_blkid}
nss-myhostname: ${have_myhostname}