summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-06-12 23:22:27 +0200
committerLennart Poettering <lennart@poettering.net>2014-06-12 23:22:27 +0200
commitf8b5d99408e016ecb3d9bcffcee8c65ef6bc26f6 (patch)
treee73178a8d73b8f2a6768b5fcbdc64c9f62cfd944 /configure.ac
parent7ec9fb4be987164b1622a4de2c6c96c52bd87b35 (diff)
sysuser: generate default snippet incorporating TTY_GID properly
When the user specifies --with-tty-gid= then we should honour that and write it to the snippet, too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c68c75930..e35d86408 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1050,8 +1050,11 @@ AM_CONDITIONAL(HAVE_SYSV_COMPAT, test "$SYSTEM_SYSV_COMPAT" = "yes")
AC_ARG_WITH([tty-gid],
[AS_HELP_STRING([--with-tty-gid=GID],
[Specify the numeric GID of the 'tty' group])],
- [AC_DEFINE_UNQUOTED(TTY_GID, [$withval], [GID of the 'tty' group])],
- [])
+ [TTY_GID="$withval"],
+ [TTY_GID="5"])
+
+AC_DEFINE_UNQUOTED(TTY_GID, [$TTY_GID], [GID of the 'tty' group])
+AC_SUBST(TTY_GID)
AC_ARG_WITH([dbuspolicydir],
AS_HELP_STRING([--with-dbuspolicydir=DIR], [D-Bus policy directory]),
@@ -1234,6 +1237,7 @@ AC_MSG_RESULT([
Extra start script: ${RC_LOCAL_SCRIPT_PATH_START}
Extra stop script: ${RC_LOCAL_SCRIPT_PATH_STOP}
Debug shell: ${SUSHELL} @ ${DEBUGTTY}
+ TTY GID: ${TTY_GID}
Maximum System UID: ${SYSTEM_UID_MAX}
Maximum System GID: ${SYSTEM_GID_MAX}