summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorFilipe Brandenburger <filbranden@google.com>2015-05-27 02:38:19 -0700
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:01:12 +0100
commit5f56749cb41c18efcc4ec2a8cd14f5277a8fab20 (patch)
tree8fb18e9a7d41fa37ad54d9a40f0c2f5647991978 /man
parent07db2f78ec6a39bdd05a8481578a641efbab3a2c (diff)
man: generate configured paths in manpages
In particular, use /lib/systemd instead of /usr/lib/systemd in distributions like Debian which still have not adopted a /usr merge setup. Use XML entities from man/custom-entities.ent to replace configured paths while doing XSLT processing of the original XML files. There was precedent of some files (such as systemd.generator.xml) which were already using this approach. This addresses most of the (manual) fixes from this patch: http://anonscm.debian.org/cgit/pkg-systemd/systemd.git/tree/debian/patches/Fix-paths-in-man-pages.patch?h=experimental-220 The idea of using generic XML entities was presented here: http://lists.freedesktop.org/archives/systemd-devel/2015-May/032240.html This patch solves almost all the issues, with the exception of: - Path to /bin/mount and /bin/umount. - Generic statements about preference of /lib over /etc. These will be handled separately by follow up patches. Tested: - With default configure settings, ran "make install" to two separate directories and compared the output to confirm they matched exactly. - Used a set of configure flags including $CONFFLAGS from Debian: http://anonscm.debian.org/cgit/pkg-systemd/systemd.git/tree/debian/rules Installed the tree and confirmed the paths use /lib/systemd instead of /usr/lib/systemd and that no other unexpected differences exist. - Confirmed that `make distcheck` still passes.
Diffstat (limited to 'man')
-rw-r--r--man/libelogind-pkgconfig.xml5
-rw-r--r--man/loginctl.xml5
-rw-r--r--man/logind.conf.xml11
-rw-r--r--man/logind.xml23
-rw-r--r--man/pam_elogind.xml5
-rw-r--r--man/sd-login.xml5
-rw-r--r--man/sd_get_seats.xml5
-rw-r--r--man/sd_login_monitor_new.xml5
-rw-r--r--man/sd_pid_get_session.xml5
-rw-r--r--man/sd_seat_get_active.xml5
-rw-r--r--man/sd_session_is_active.xml5
-rw-r--r--man/sd_uid_get_state.xml5
12 files changed, 60 insertions, 24 deletions
diff --git a/man/libelogind-pkgconfig.xml b/man/libelogind-pkgconfig.xml
index c940b15b3..bda91ce50 100644
--- a/man/libelogind-pkgconfig.xml
+++ b/man/libelogind-pkgconfig.xml
@@ -1,6 +1,9 @@
<?xml version="1.0"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
- "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<refsect1>
<title>Notes</title>
diff --git a/man/loginctl.xml b/man/loginctl.xml
index 4e09e7a1c..9fecb7a33 100644
--- a/man/loginctl.xml
+++ b/man/loginctl.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
diff --git a/man/logind.conf.xml b/man/logind.conf.xml
index 9332e8075..4deaadb76 100644
--- a/man/logind.conf.xml
+++ b/man/logind.conf.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
@@ -48,10 +51,10 @@
</refnamediv>
<refsynopsisdiv>
- <para><filename>/etc/systemd/logind.conf</filename></para>
- <para><filename>/etc/systemd/logind.conf.d/*.conf</filename></para>
+ <para><filename>&pkgsysconfdir;/logind.conf</filename></para>
+ <para><filename>&pkgsysconfdir;/logind.conf.d/*.conf</filename></para>
<para><filename>/run/systemd/logind.conf.d/*.conf</filename></para>
- <para><filename>/usr/lib/systemd/logind.conf.d/*.conf</filename></para>
+ <para><filename>&rootlibexecdir;/logind.conf.d/*.conf</filename></para>
</refsynopsisdiv>
<refsect1>
diff --git a/man/logind.xml b/man/logind.xml
index 7afacbf34..1416d884c 100644
--- a/man/logind.xml
+++ b/man/logind.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
@@ -21,10 +24,10 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="logind.service">
+<refentry id="systemd-logind.service" conditional='ENABLE_LOGIND'>
<refentryinfo>
- <title>logind.service</title>
+ <title>systemd-logind.service</title>
<productname>systemd</productname>
<authorgroup>
@@ -38,25 +41,25 @@
</refentryinfo>
<refmeta>
- <refentrytitle>logind.service</refentrytitle>
+ <refentrytitle>systemd-logind.service</refentrytitle>
<manvolnum>8</manvolnum>
</refmeta>
<refnamediv>
- <refname>logind.service</refname>
- <refname>logind</refname>
+ <refname>systemd-logind.service</refname>
+ <refname>systemd-logind</refname>
<refpurpose>Login manager</refpurpose>
</refnamediv>
<refsynopsisdiv>
- <para><filename>logind.service</filename></para>
- <para><filename>/usr/lib/systemd/logind</filename></para>
+ <para><filename>systemd-logind.service</filename></para>
+ <para><filename>&rootlibexecdir;/systemd-logind</filename></para>
</refsynopsisdiv>
<refsect1>
<title>Description</title>
- <para><command>logind</command> is a system service that
+ <para><command>systemd-logind</command> is a system service that
manages user logins. It is responsible for:</para>
<itemizedlist>
@@ -100,7 +103,7 @@
<para>See the <ulink
url="http://www.freedesktop.org/wiki/Software/systemd/logind">
logind D-Bus API Documentation</ulink> for information about the
- APIs <filename>logind</filename> provides.</para>
+ APIs <filename>systemd-logind</filename> provides.</para>
<para>For more information on the inhibition logic see the <ulink
url="http://www.freedesktop.org/wiki/Software/systemd/inhibit">Inhibitor
diff --git a/man/pam_elogind.xml b/man/pam_elogind.xml
index 7c3690aab..d2f183b76 100644
--- a/man/pam_elogind.xml
+++ b/man/pam_elogind.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
diff --git a/man/sd-login.xml b/man/sd-login.xml
index 06ffc6906..d220025b5 100644
--- a/man/sd-login.xml
+++ b/man/sd-login.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
diff --git a/man/sd_get_seats.xml b/man/sd_get_seats.xml
index c6b133e66..72cf2f9ae 100644
--- a/man/sd_get_seats.xml
+++ b/man/sd_get_seats.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
diff --git a/man/sd_login_monitor_new.xml b/man/sd_login_monitor_new.xml
index 7319c061c..f24d8b3ce 100644
--- a/man/sd_login_monitor_new.xml
+++ b/man/sd_login_monitor_new.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
diff --git a/man/sd_pid_get_session.xml b/man/sd_pid_get_session.xml
index fac072a4c..60bc7ed88 100644
--- a/man/sd_pid_get_session.xml
+++ b/man/sd_pid_get_session.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
diff --git a/man/sd_seat_get_active.xml b/man/sd_seat_get_active.xml
index e0002c205..8fda8b3f8 100644
--- a/man/sd_seat_get_active.xml
+++ b/man/sd_seat_get_active.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
diff --git a/man/sd_session_is_active.xml b/man/sd_session_is_active.xml
index 069cbe091..70d201e29 100644
--- a/man/sd_session_is_active.xml
+++ b/man/sd_session_is_active.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.
diff --git a/man/sd_uid_get_state.xml b/man/sd_uid_get_state.xml
index 4218f7381..fbadb5016 100644
--- a/man/sd_uid_get_state.xml
+++ b/man/sd_uid_get_state.xml
@@ -1,6 +1,9 @@
<?xml version='1.0'?> <!--*-nxml-*-->
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
- "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY % entities SYSTEM "custom-entities.ent" >
+%entities;
+]>
<!--
This file is part of systemd.