summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-19 17:02:37 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit18b586d62b52299ca6a88ff8a5997c5ca767dcdc (patch)
tree9747705c4c39f20b7f63343da2c9b5a462c97a39 /meson.build
parentc9182982285c084db03437583705a63d24acd599 (diff)
rpm: add macros for common configuration dirs
%_environmnentdir /usr/lib/environment.d %_modulesloaddir /usr/lib/modules-load.d %_modprobedir /usr/lib/modprobe.d This makes installing files there more convenient because people don't need to construct the path from %_prefix/lib/… . See https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/GBF5WJLTQVSXMHGYGBF3723ZYCWFBR7C/.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c18438a6b..866ee5abb 100644
--- a/meson.build
+++ b/meson.build
@@ -303,6 +303,7 @@ substs.set('rootlibexecdir', rootlibexecdir)
#endif // 0
substs.set('udevrulesdir', udevrulesdir)
substs.set('udevlibexecdir', udevlibexecdir)
+substs.set('environmentdir', environmentdir)
#if 0 /// UNNEEDED by elogind
# substs.set('catalogdir', catalogdir)
# substs.set('tmpfilesdir', tmpfilesdir)
@@ -310,6 +311,7 @@ substs.set('udevlibexecdir', udevlibexecdir)
# substs.set('sysctldir', sysctldir)
# substs.set('binfmtdir', binfmtdir)
# substs.set('modulesloaddir', modulesloaddir)
+# substs.set('modprobedir', modprobedir)
# substs.set('systemgeneratordir', systemgeneratordir)
# substs.set('usergeneratordir', usergeneratordir)
# substs.set('systemenvgeneratordir', systemenvgeneratordir)
@@ -1914,6 +1916,7 @@ executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
+executable('elogind-user-runtime-dir',
user_runtime_dir_sources,
include_directories : includes,
link_with : [libshared, liblogind_core],
@@ -3053,8 +3056,9 @@ if git.found()
'tags',
output : 'tags',
command : [env, 'etags', '-o', '@0@/TAGS'.format(meson.current_source_dir())] + all_files)
- run_target(
+ custom_target(
'ctags',
+ output : 'ctags',
command : [env, 'ctags', '-o', '@0@/tags'.format(meson.current_source_dir())] + all_files)
endif