summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-01-26 16:15:17 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:50:20 +0200
commit1e586f516c80afd3fac03c49203d49ea89729dbe (patch)
tree8b2c9892e1900447c0ee6c15e4bc3d33cc8a7c58 /meson.build
parent982bf4f3897a1ff9253cac7bc2f90a7984207f37 (diff)
meson: use env object instead of string in tags targets
I used 'tags' before because this way we avoided a unnecessary line about 'env' detection. But we cannot use 'env' in test(), so previous commit added 'env' detection. We might just as well use it in custom_target().
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 2e592cee6..81a414fcb 100644
--- a/meson.build
+++ b/meson.build
@@ -2955,11 +2955,11 @@ if git.found()
custom_target(
'tags',
output : 'tags',
- command : ['env', 'etags', '-o', '@0@/TAGS'.format(meson.current_source_dir())] + all_files)
+ command : [env, 'etags', '-o', '@0@/TAGS'.format(meson.current_source_dir())] + all_files)
custom_target(
'ctags',
output : 'ctags',
- command : ['env', 'ctags', '-o', '@0@/tags'.format(meson.current_source_dir())] + all_files)
+ command : [env, 'ctags', '-o', '@0@/tags'.format(meson.current_source_dir())] + all_files)
endif
#if 0 /// UNNEEDED by elogind