summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEvegeny Vereshchagin <evvers@ya.ru>2018-05-18 10:52:17 +0000
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit43810cf7ec7e3b0b9dd0637334befb70072ce10b (patch)
tree3503fa2c6187fd50c752e9a3940aa1ce7d9107b2 /meson.build
parentbfd0ddb66c3640d70399ebce253f2a80285c29ca (diff)
meson: use run_target for generating tags with ctags
In https://github.com/systemd/systemd/pull/6561, `run_target` was changed to `custom_target`, which inadvertently caused relative paths to be passed to ctags due to https://github.com/mesonbuild/meson/issues/3589. The switch to `run_target` causes absolute paths to be passed again and makes it easier to jump from file to file, hopefully delaying the need to exit Vim :-)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c18b5b496..c18438a6b 100644
--- a/meson.build
+++ b/meson.build
@@ -1913,6 +1913,7 @@ executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
+executable('elogind-user-runtime-dir',
user_runtime_dir_sources,
include_directories : includes,
link_with : [libshared, liblogind_core],
@@ -3052,9 +3053,8 @@ if git.found()
'tags',
output : 'tags',
command : [env, 'etags', '-o', '@0@/TAGS'.format(meson.current_source_dir())] + all_files)
- custom_target(
+ run_target(
'ctags',
- output : 'ctags',
command : [env, 'ctags', '-o', '@0@/tags'.format(meson.current_source_dir())] + all_files)
endif