summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCaio Marcelo de Oliveira Filho <cmarcelo@gmail.com>2018-02-19 01:37:19 -0800
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:58:58 +0200
commit6074e92552ced541803bbed62c877e795ddddc17 (patch)
treeb5b01d55ebbd201584cc1cd476d00c216101ae63 /meson.build
parent8172c1d4f5327a4081a4cd9934b6ad34f8a8e725 (diff)
meson: use multiline string syntax (#8214)
The single quote working with multiple lines is likely to be unintended. With current versions of meson, it also causes error messages after it to report the wrong line number. Use the documented syntax instead.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6d16024c3..b4bb15932 100644
--- a/meson.build
+++ b/meson.build
@@ -417,7 +417,7 @@ foreach arg : ['unused-parameter',
endif
endforeach
-if cc.compiles('
+if cc.compiles('''
#include <time.h>
#include <inttypes.h>
typedef uint64_t usec_t;
@@ -426,7 +426,7 @@ if cc.compiles('
struct timespec now;
return 0;
}
-', name : '-Werror=shadow with local shadowing')
+''', name : '-Werror=shadow with local shadowing')
add_project_arguments('-Werror=shadow', language : 'c')
endif