summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-19 20:54:46 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:49:48 +0200
commit70f9a30a6058ba92d0b93da00727cf76c1592633 (patch)
tree2ac867dbacd98eae2b1d5c77fb78199b80df4e8d /meson.build
parentd86cd5bf77ef02fd5825ecccb64dc64ea6e5d4e3 (diff)
meson: rename libudev_internal to libudev_static and link into libudev
This reduces the meson man=false target count to 1281. v2: - link test-engine with libshared instead of libsystemd_static Previous version built fine on F27, but fails on F26 with the following error: /usr/bin/ld: /tmp/ccr8HRGw.ltrans6.ltrans.o: undefined reference to symbol '__start_BUS_ERROR_MAP@@SD_SHARED' /home/zbyszek/fedora/systemd/systemd-9d5aae75c64f5583a110f03b94816aacc03bbf4d/x86_64-redhat-linux-gnu/src/shared/libsystemd-shared-236.so: error adding symbols: DSO missing from command line v3: - add libudev_basic
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index bbd4ed340..e8e82ec27 100644
--- a/meson.build
+++ b/meson.build
@@ -2500,7 +2500,7 @@ executable('elogind-cgroups-agent',
# 'src/hwdb/hwdb.c',
# 'src/libsystemd/sd-hwdb/hwdb-internal.h',
# include_directories : includes,
-# link_with : [libudev_internal],
+# link_with : [libudev_static],
# install_rpath : udev_rpath,
# install : true,
# install_dir : rootbindir)
@@ -2533,7 +2533,7 @@ executable('elogind-cgroups-agent',
# c_args : ['-DLOG_REALM=LOG_REALM_UDEV'],
# link_with : [libudev_core,
# libsystemd_network,
-# libudev_internal],
+# libudev_static],
# dependencies : [threads,
# libkmod,
# libidn,
@@ -2550,7 +2550,7 @@ executable('elogind-cgroups-agent',
# include_directories : includes,
# link_with : [libudev_core,
# libsystemd_network,
-# libudev_internal],
+# libudev_static],
# dependencies : [threads,
# libkmod,
# libidn,
@@ -2624,7 +2624,7 @@ executable('elogind-cgroups-agent',
# include_directories : includes,
# link_with : [libnetworkd_core,
# libsystemd_network,
-# libudev_internal,
+# libudev_static,
# libshared],
# dependencies : [threads],
# install_rpath : rootlibexecdir,