summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2017-12-20 12:51:14 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:50:01 +0200
commit8d30fe45682bcbe4f9d1e739606e7a1a4692aad0 (patch)
tree69233324f4e0922b18a8a144e2a2f96007f4ddac /meson.build
parent423ab1579fcfc0d9616432da5cc59cc4e36c9c5e (diff)
meson: resurrect API documentation target
We had this functionality back in Automake times, let's resurrect it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e0e1f8478..bdda7561d 100644
--- a/meson.build
+++ b/meson.build
@@ -2869,6 +2869,14 @@ endif
############################################################
+meson_check_api_docs_sh = find_program('tools/meson-check-api-docs.sh')
+run_target(
+ 'check-api-docs',
+ depends : [man, libelogind, libudev],
+ command : [meson_check_api_docs_sh, libelogind.full_path(), libudev.full_path()])
+
+############################################################
+
status = [
'@0@ @1@'.format(meson.project_name(), meson.project_version()),