summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-02-15 11:43:08 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:58:56 +0200
commit9485fe3b7cae0f4a9f4163f380c1d07448a68e43 (patch)
treec10253be98f7471c32c5d3e4202b2a5f131d9ea1 /meson.build
parent811fb7d0179eeed9c928e4a6ac3c8aaac4c3800d (diff)
meson: add -Dmemory-accounting-default=true|false
This makes it easy to set the default for distributions and users which want to default to off because they primarily use older kernels.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 052a955e6..6d16024c3 100644
--- a/meson.build
+++ b/meson.build
@@ -218,6 +218,8 @@ if pamconfdir == ''
pamconfdir = join_paths(sysconfdir, 'pam.d')
endif
+memory_accounting_default = get_option('memory-accounting-default')
+
conf.set_quoted('PKGSYSCONFDIR', pkgsysconfdir)
conf.set_quoted('SYSTEM_CONFIG_UNIT_PATH', join_paths(pkgsysconfdir, 'system'))
#if 0 /// UNNEEDED by elogind
@@ -275,6 +277,8 @@ conf.set_quoted('ROOTLIBEXECDIR', rootlibexecdir)
# conf.set_quoted('USER_KEYRING_PATH', join_paths(pkgsysconfdir, 'import-pubring.gpg'))
# conf.set_quoted('DOCUMENT_ROOT', join_paths(pkgdatadir, 'gatewayd'))
#endif // 0
+conf.set('MEMORY_ACCOUNTING_DEFAULT', memory_accounting_default ? 'true' : 'false')
+conf.set_quoted('MEMORY_ACCOUNTING_DEFAULT_ON_OFF', memory_accounting_default ? 'on' : 'off')
conf.set_quoted('ABS_BUILD_DIR', meson.build_root())
conf.set_quoted('ABS_SRC_DIR', meson.source_root())
@@ -321,6 +325,7 @@ substs.set('VARLOGDIR', varlogdir)
# substs.set('RC_LOCAL_SCRIPT_PATH_START', get_option('rc-local'))
# substs.set('RC_LOCAL_SCRIPT_PATH_STOP', get_option('halt-local'))
#endif // 0
+substs.set('MEMORY_ACCOUNTING_DEFAULT', memory_accounting_default ? 'yes' : 'no')
#####################################################################