summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authortblume <Thomas.Blume@suse.com>2018-02-01 22:46:15 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:58:47 +0200
commit9f50507f906656f0e5abc4a71e3e6c6a8197743a (patch)
tree76caf94f2ccf1d0d4eafd8cbdc665ffcffa836b3 /meson.build
parent8fdf8da964052a2623d3b1dd72ac7aed233f42ce (diff)
meson.build: make docdir configurable (#8068)
SUSE is using a different docdir, so the path should be configurable
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 6 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index 96fb8b134..052a955e6 100644
--- a/meson.build
+++ b/meson.build
@@ -412,7 +412,7 @@ foreach arg : ['unused-parameter',
endif
endforeach
-if cc.compiles('''
+if cc.compiles('
#include <time.h>
#include <inttypes.h>
typedef uint64_t usec_t;
@@ -421,7 +421,7 @@ if cc.compiles('''
struct timespec now;
return 0;
}
-''', name : '-Werror=shadow with local shadowing')
+', name : '-Werror=shadow with local shadowing')
add_project_arguments('-Werror=shadow', language : 'c')
endif
@@ -754,11 +754,8 @@ system_uid_max = get_option('system-uid-max')
if system_uid_max == ''
system_uid_max = run_command(
awk,
- '/^\s*SYS_UID_MAX\s+/ { uid=$2 } END { print uid }',
- '/etc/login.defs').stdout().strip()
- if system_uid_max == ''
- system_uid_max = '999'
- endif
+ 'BEGIN { uid=999 } /^\s*SYS_UID_MAX\s+/ { uid=$2 } END { print uid }',
+ '/etc/login.defs').stdout()
endif
system_uid_max = system_uid_max.to_int()
conf.set('SYSTEM_UID_MAX', system_uid_max)
@@ -769,11 +766,8 @@ system_gid_max = get_option('system-gid-max')
if system_gid_max == ''
system_gid_max = run_command(
awk,
- '/^\s*SYS_GID_MAX\s+/ { gid=$2 } END { print gid }',
- '/etc/login.defs').stdout().strip()
- if system_gid_max == ''
- system_gid_max = '999'
- endif
+ 'BEGIN { gid=999 } /^\s*SYS_GID_MAX\s+/ { gid=$2 } END { print gid }',
+ '/etc/login.defs').stdout()
endif
system_gid_max = system_gid_max.to_int()
conf.set('SYSTEM_GID_MAX', system_gid_max)