summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2018-01-25 15:30:15 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:50:19 +0200
commitb45d972351bd084c74b22fcd707b2af62c9d2808 (patch)
treed04beed4c4c28f6627ead46469fa72830436d2f2 /meson.build
parent5ccd7ad5d67361f440f6ce89f66211de75563025 (diff)
firstboot: Include <crypt.h> for declaration of crypt() if needed (#7944)
Not every target system may provide a crypt() function in its stdlibc and may use an external or replacement library, like libxcrypt, for providing such functions. See https://fedoraproject.org/wiki/Changes/Replace_glibc_libcrypt_with_libxcrypt.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 80907cbd0..4331af1fd 100644
--- a/meson.build
+++ b/meson.build
@@ -16,7 +16,7 @@
# along with elogind; If not, see <http://www.gnu.org/licenses/>.
project('elogind', 'c',
- version : '237',
+ version : '236',
license : 'LGPLv2+',
default_options: [
'c_std=gnu99',
@@ -28,8 +28,8 @@ project('elogind', 'c',
)
#if 0 /// UNNEEDED by elogind - libudev is external
-# libsystemd_version = '0.21.0'
-# libudev_version = '1.6.9'
+# libsystemd_version = '0.20.0'
+# libudev_version = '1.6.8'
#else
libelogind_version = '0.20.0'
#endif // 0
@@ -665,7 +665,8 @@ conf.set('GPERF_LEN_TYPE', gperf_len_type,
if not cc.has_header('sys/capability.h')
error('POSIX caps headers not found')
endif
-foreach header : ['linux/btrfs.h',
+foreach header : ['crypt.h',
+ 'linux/btrfs.h',
'linux/memfd.h',
'linux/vm_sockets.h',
'sys/auxv.h',