summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Mack <daniel@zonque.org>2016-10-18 17:57:10 +0200
committerSven Eden <yamakuzure@gmx.net>2017-11-20 17:28:50 +0100
commitb605cf820c4831451fd009825a914d6f98045219 (patch)
tree6320971d755d18f28b3387d9de29ea28052d57a8 /meson.build
parent294d3039be600ee7fbe43222fcf7084c99e63b94 (diff)
Add abstraction model for BPF programs
This object takes a number of bpf_insn members and wraps them together with the in-kernel reference id. Will be needed by the firewall code.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 11 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 06406b782..dea963aa8 100644
--- a/meson.build
+++ b/meson.build
@@ -496,6 +496,8 @@ foreach ident : [
#include <keyutils.h>'''],
['copy_file_range', '''#include <sys/syscall.h>
#include <unistd.h>'''],
+ ['bpf', '''#include <sys/syscall.h>
+ #include <unistd.h>'''],
['explicit_bzero' , '''#include <string.h>'''],
]
@@ -761,7 +763,7 @@ endif
#if 0 /// UNNEEDED by elogind
# libmount = dependency('mount',
-# version : '>= 2.27')
+# version : '>= 2.30')
#
# want_seccomp = get_option('seccomp')
# if want_seccomp != 'false'
@@ -2460,17 +2462,17 @@ executable('elogind-cgroups-agent',
# install_rpath : rootlibexecdir,
# install : true,
# install_dir : rootlibexecdir)
-# endif
#
# exe = executable('networkctl',
-# networkctl_sources,
-# include_directories : includes,
-# link_with : [libsystemd_network,
+# networkctl_sources,
+# include_directories : includes,
+# link_with : [libsystemd_network,
# libshared],
-# install_rpath : rootlibexecdir,
-# install : true,
-# install_dir : rootbindir)
-# public_programs += [exe]
+# install_rpath : rootlibexecdir,
+# install : true,
+# install_dir : rootbindir)
+# public_programs += [exe]
+# endif
#endif // 0
############################################################