summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCaio Marcelo de Oliveira Filho <cmarcelo@gmail.com>2018-02-19 01:37:19 -0800
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:54:01 +0200
commitcf6df4681f466a9716e2ae5a0dfaf9f1b96b6145 (patch)
tree6b005fb9420e8fe6f424f76503a1b0ed5c9fc634 /meson.build
parentaa3cde5d453e3dd0f259827f7f02874d7260047e (diff)
meson: use multiline string syntax (#8214)
The single quote working with multiple lines is likely to be unintended. With current versions of meson, it also causes error messages after it to report the wrong line number. Use the documented syntax instead. (cherry picked from commit 9e70f2f81821efa4797d89c06d1f04c11e86015e)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e11b3ff82..05bbcc67d 100644
--- a/meson.build
+++ b/meson.build
@@ -167,6 +167,8 @@ modprobedir = join_paths(rootprefixdir, 'lib/modprobe.d')
# systemdstatedir = join_paths(localstatedir, 'lib/systemd')
# catalogstatedir = join_paths(systemdstatedir, 'catalog')
# randomseeddir = join_paths(localstatedir, 'lib/systemd')
+#
+# docdir = get_option('docdir')
# if docdir == ''
# docdir = join_paths(datadir, 'doc/systemd')
# endif
@@ -410,7 +412,7 @@ foreach arg : ['unused-parameter',
endif
endforeach
-if cc.compiles('
+if cc.compiles('''
#include <time.h>
#include <inttypes.h>
typedef uint64_t usec_t;
@@ -419,7 +421,7 @@ if cc.compiles('
struct timespec now;
return 0;
}
-', name : '-Werror=shadow with local shadowing')
+''', name : '-Werror=shadow with local shadowing')
add_project_arguments('-Werror=shadow', language : 'c')
endif