summaryrefslogtreecommitdiff
path: root/src/basic/ring.h
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2016-12-16 12:09:41 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:18:01 +0100
commit1cfc78c91965df340cdde100ad6cb3ed50b28927 (patch)
treeadc3d49b97131cd3e70edff05b14e9b67926e404 /src/basic/ring.h
parent86e97d599f8b1ca379dce64fadac9b8f6b002ac5 (diff)
Prep v221: Update and clean up build system to sync with upstream
This commit replays the moving around of source files that have been done between systemd-219 and systemd-221. Further the Makefile.am is synchronized with the upstream version and then "re-cleaned". A lot of functions, that are not used anywhere in elogind have been coated into #if 0/#endif directives to further shorten the list of dependencies. All unneeded files have been removed.
Diffstat (limited to 'src/basic/ring.h')
-rw-r--r--src/basic/ring.h56
1 files changed, 56 insertions, 0 deletions
diff --git a/src/basic/ring.h b/src/basic/ring.h
new file mode 100644
index 000000000..fc857e7a9
--- /dev/null
+++ b/src/basic/ring.h
@@ -0,0 +1,56 @@
+/*-*- Mode: C; c-basic-offset: 8; indent-tabs-mode: nil -*-*/
+
+#pragma once
+
+/***
+ This file is part of systemd.
+
+ Copyright 2014 David Herrmann <dh.herrmann@gmail.com>
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+
+typedef struct Ring Ring;
+
+struct Ring {
+ uint8_t *buf; /* buffer or NULL */
+ size_t size; /* actual size of @buf */
+ size_t start; /* start position of ring */
+ size_t used; /* number of actually used bytes */
+};
+
+/* flush buffer so it is empty again */
+// UNNEEDED void ring_flush(Ring *r);
+
+/* flush buffer, free allocated data and reset to initial state */
+void ring_clear(Ring *r);
+
+/* get pointers to buffer data and their length */
+size_t ring_peek(Ring *r, struct iovec *vec);
+
+/* copy data into external linear buffer */
+// UNNEEDED size_t ring_copy(Ring *r, void *buf, size_t size);
+
+/* push data to the end of the buffer */
+int ring_push(Ring *r, const void *u8, size_t size);
+
+/* pull data from the front of the buffer */
+void ring_pull(Ring *r, size_t size);
+
+/* return size of occupied buffer in bytes */
+static inline size_t ring_get_size(Ring *r)
+{
+ return r->used;
+}