summaryrefslogtreecommitdiff
path: root/src/basic
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-08-10 17:41:29 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit48d68297393c8b3699dd1ccabfe2e30b84c0a624 (patch)
tree013f7e15a1e949782803a64002ef188ee3b8d1c4 /src/basic
parent11a069d1c3a71ea239275b1a1122d48ef9c45fb1 (diff)
Build system: Fix various issues that came from errornous migration.
No matter how much advanced check_tree.pl is, there are plenty possibilities where upstream changes can be transported wrong. Mainly adding something we then have to mask out. But at the end of the day this is actually wanted, so we do not miss important changes.
Diffstat (limited to 'src/basic')
-rw-r--r--src/basic/meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/basic/meson.build b/src/basic/meson.build
index 56b8b06b3..c4b495e1d 100644
--- a/src/basic/meson.build
+++ b/src/basic/meson.build
@@ -459,9 +459,11 @@ foreach item : [['cap', cap_list_txt, 'capability', ''],
endforeach
basic_sources += [missing_h] + generated_gperf_headers
-basic_gcrypt_sources = files(
- 'gcrypt-util.c',
- 'gcrypt-util.h')
+#if 0 /// elogind does not need gcrypt
+# basic_gcrypt_sources = files(
+# 'gcrypt-util.c',
+# 'gcrypt-util.h')
+#endif // 0
libbasic = static_library(
'basic',
@@ -469,7 +471,7 @@ libbasic = static_library(
include_directories : includes,
dependencies : [threads,
libcap,
-#if 0 /// no blkid in elogind
+#if 0 /// Neither blkid nor libmount in elogind
# libblkid,
# libmount,
#endif // 0