summaryrefslogtreecommitdiff
path: root/src/core/macros.systemd.in
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-06-21 22:14:17 +0200
committerLennart Poettering <lennart@poettering.net>2012-06-21 22:14:17 +0200
commit590f18a27c05524f5332819b9580afc327b95d84 (patch)
tree71161407dccc6e608734e64e3a522b815c899f0a /src/core/macros.systemd.in
parent20747498c68575646fae88f4dd270fab219a25a6 (diff)
rpm: include RPM macro definition for .spec snippets
Let's try to standardize a bit the RPM macros used for installing/uninstalling services. This only covers the non-SysV compat bits, since that tends to vary widely between the various distros. Usage: Add %{?systemd_requires} to the header of the spec file. And then: %post %systemd_post foobar.service %preun %systemd_preun foobar.service %postun %systemd_postun foobar.service And, instead of the latter, in case the service shall be restarted on updates: %postun %systemd_postun_restart foobar.service
Diffstat (limited to 'src/core/macros.systemd.in')
-rw-r--r--src/core/macros.systemd.in55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/core/macros.systemd.in b/src/core/macros.systemd.in
new file mode 100644
index 000000000..86e869307
--- /dev/null
+++ b/src/core/macros.systemd.in
@@ -0,0 +1,55 @@
+# -*- Mode: makefile; indent-tabs-mode: t -*- */
+#
+# This file is part of systemd.
+#
+# Copyright 2012 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# RPM macros for packages installing systemd unit files
+
+%_unitdir @systemunitdir@
+
+%systemd_requires \
+Requires(post): systemd \
+Requires(preun): systemd \
+Requires(postun): systemd \
+%{nil}
+
+%systemd_post() \
+if [ $1 -eq 1 ] ; then \
+ # Initial installation \
+ @rootbindir@/systemctl preset %{?*} >/dev/null 2>&1 || : \
+fi \
+%{nil}
+
+%systemd_preun() \
+if [ $1 -eq 0 ] ; then \
+ # Package removal, not upgrade \
+ @rootbindir@/systemctl --no-reload disable %{?*} > /dev/null 2>&1 || : \
+ @rootbindir@/systemctl stop %{?*} > /dev/null 2>&1 || : \
+fi \
+%{nil}
+
+%systemd_postun() \
+@rootbindir@/systemctl daemon-reload >/dev/null 2>&1 || : \
+%{nil}
+
+%systemd_postun_with_restart() \
+@rootbindir@/systemctl daemon-reload >/dev/null 2>&1 || : \
+if [ $1 -ge 1 ] ; then \
+ # Package upgrade, not uninstall \
+ @rootbindir@/systemctl try-restart %{?*} >/dev/null 2>&1 || : \
+fi \
+%{nil}