summaryrefslogtreecommitdiff
path: root/src/gpt-auto-generator/gpt-auto-generator.c
diff options
context:
space:
mode:
authorThomas Hindoe Paaboel Andersen <phomes@gmail.com>2013-12-10 22:30:46 +0100
committerThomas Hindoe Paaboel Andersen <phomes@gmail.com>2013-12-10 22:30:46 +0100
commit96115cdfe0241ae9b4e7177cd3874c0a93d00b39 (patch)
tree0d5c641ceb00c3b1535dc2b1de328f36d97c4060 /src/gpt-auto-generator/gpt-auto-generator.c
parentff4994c50717be97ad4df3dc77fce5125f881c7c (diff)
fix scan-build issues
The static analyzer scan-build had a few issues with analysing parts of systemd. gpt-auto-generator.c: scan-build could not find blkid.h. Whether it should be blkid.h or blkid/blkid.h seems to depend on the version used. We already use blkid/blkid.h in udev-builtin-blkid.c so it seems safe to use that here too. Makefile.am: Moved some -D's from CFLAGS to CPPFLAGS. I also simplified them a bit and got rid of a left over DBUS_CFLAGS. test-cgroup-mask.c/test-sched-prio.c A variable was added to store the replaced TEST_DIR. When wrapped in an assert_se TEST_DIR was not replaced in the logged error. While not an issue introduced in this patch we might as well fix it up while we are here.
Diffstat (limited to 'src/gpt-auto-generator/gpt-auto-generator.c')
-rw-r--r--src/gpt-auto-generator/gpt-auto-generator.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gpt-auto-generator/gpt-auto-generator.c b/src/gpt-auto-generator/gpt-auto-generator.c
index 3cbafa4d5..017c35dcd 100644
--- a/src/gpt-auto-generator/gpt-auto-generator.c
+++ b/src/gpt-auto-generator/gpt-auto-generator.c
@@ -24,7 +24,7 @@
#include <fcntl.h>
#include <sys/ioctl.h>
#include <sys/statfs.h>
-#include <blkid.h>
+#include <blkid/blkid.h>
#ifdef HAVE_LINUX_BTRFS_H
#include <linux/btrfs.h>