summaryrefslogtreecommitdiff
path: root/src/libsystemd/sd-utf8
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2014-01-21 14:10:18 +0100
committerTom Gundersen <teg@jklm.no>2014-01-21 14:41:35 +0100
commit607553f9306286fdccf0b356bc3d1087adfe21c4 (patch)
treeeedb987304b96ecaf22348c372a93d6ac5fbf594 /src/libsystemd/sd-utf8
parent43d9c2b5848b1363b659c38443c1c94db57415fd (diff)
libsystemd: split up into subdirs
We still only produce on .so, but let's keep the sources separate to make things a bit less messy.
Diffstat (limited to 'src/libsystemd/sd-utf8')
l---------src/libsystemd/sd-utf8/Makefile1
-rw-r--r--src/libsystemd/sd-utf8/sd-utf8.c36
2 files changed, 37 insertions, 0 deletions
diff --git a/src/libsystemd/sd-utf8/Makefile b/src/libsystemd/sd-utf8/Makefile
new file mode 120000
index 000000000..94aaae2c4
--- /dev/null
+++ b/src/libsystemd/sd-utf8/Makefile
@@ -0,0 +1 @@
+../../Makefile \ No newline at end of file
diff --git a/src/libsystemd/sd-utf8/sd-utf8.c b/src/libsystemd/sd-utf8/sd-utf8.c
new file mode 100644
index 000000000..6f2aa6064
--- /dev/null
+++ b/src/libsystemd/sd-utf8/sd-utf8.c
@@ -0,0 +1,36 @@
+/*-*- Mode: C; c-basic-offset: 8; indent-tabs-mode: nil -*-*/
+
+/***
+ This file is part of systemd.
+
+ Copyright 2013 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+#include "util.h"
+#include "utf8.h"
+#include "sd-utf8.h"
+
+_public_ const char *sd_utf8_is_valid(const char *s) {
+ assert_return(s, NULL);
+
+ return utf8_is_valid(s);
+}
+
+_public_ const char *sd_ascii_is_valid(const char *s) {
+ assert_return(s, NULL);
+
+ return ascii_is_valid(s);
+}