summaryrefslogtreecommitdiff
path: root/src/login/logind-user.c
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-08-20 10:53:41 +0200
committerAndy Wingo <wingo@pobox.com>2015-08-20 10:53:41 +0200
commitb1d35da9e405abaab2ff540baf2e54087f92e881 (patch)
treeeabc375eb9bfff2409f5895640d5700dea0e1c58 /src/login/logind-user.c
parent92947a0878c5d129adb37ddbfdef35274ef5c6ae (diff)
Actually working with pam
* src/login/logind-user.c (user_start): Don't start slices and systemd-user services. * src/login/logind-dbus.c (method_create_session): Send a reply directly instead of waiting on systemd that isn't there. * configure.ac: Bump version.
Diffstat (limited to 'src/login/logind-user.c')
-rw-r--r--src/login/logind-user.c2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/login/logind-user.c b/src/login/logind-user.c
index 294c1e799..c0d0b967a 100644
--- a/src/login/logind-user.c
+++ b/src/login/logind-user.c
@@ -446,6 +446,7 @@ int user_start(User *u) {
if (r < 0)
return r;
+#if 0
/* Create cgroup */
r = user_start_slice(u);
if (r < 0)
@@ -455,6 +456,7 @@ int user_start(User *u) {
r = user_start_service(u);
if (r < 0)
return r;
+#endif
if (!dual_timestamp_is_set(&u->timestamp))
dual_timestamp_get(&u->timestamp);