summaryrefslogtreecommitdiff
path: root/src/login
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2016-12-16 12:09:41 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:18:01 +0100
commit1cfc78c91965df340cdde100ad6cb3ed50b28927 (patch)
treeadc3d49b97131cd3e70edff05b14e9b67926e404 /src/login
parent86e97d599f8b1ca379dce64fadac9b8f6b002ac5 (diff)
Prep v221: Update and clean up build system to sync with upstream
This commit replays the moving around of source files that have been done between systemd-219 and systemd-221. Further the Makefile.am is synchronized with the upstream version and then "re-cleaned". A lot of functions, that are not used anywhere in elogind have been coated into #if 0/#endif directives to further shorten the list of dependencies. All unneeded files have been removed.
Diffstat (limited to 'src/login')
-rw-r--r--src/login/elogind.conf (renamed from src/login/logind.conf)2
-rw-r--r--src/login/logind-button.h34
-rw-r--r--src/login/logind.c5
3 files changed, 20 insertions, 21 deletions
diff --git a/src/login/logind.conf b/src/login/elogind.conf
index 6df6f04c7..25edfce6f 100644
--- a/src/login/logind.conf
+++ b/src/login/elogind.conf
@@ -9,7 +9,7 @@
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
-# See logind.conf(5) for details.
+# See elogind.conf(5) for details.
[Login]
#NAutoVTs=6
diff --git a/src/login/logind-button.h b/src/login/logind-button.h
index 80d93c7e6..95bb6a524 100644
--- a/src/login/logind-button.h
+++ b/src/login/logind-button.h
@@ -5,7 +5,7 @@
/***
This file is part of systemd.
- Copyright 2012 Lennart Poettering
+ Copyright 2014 Daniel Mack
systemd is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License as published by
@@ -21,26 +21,24 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
***/
-typedef struct Button Button;
+typedef struct BusEndpoint BusEndpoint;
+typedef struct BusEndpointPolicy BusEndpointPolicy;
-#include "logind.h"
-
-struct Button {
- Manager *manager;
-
- sd_event_source *io_event_source;
- sd_event_source *check_event_source;
+#include "hashmap.h"
+#include "bus-policy.h"
+struct BusEndpointPolicy {
char *name;
- char *seat;
- int fd;
+ BusPolicyAccess access;
+};
- bool lid_closed;
- bool docked;
+struct BusEndpoint {
+ Hashmap *policy_hash;
};
-Button* button_new(Manager *m, const char *name);
-void button_free(Button*b);
-int button_open(Button *b);
-int button_set_seat(Button *b, const char *sn);
-int button_check_switches(Button *b);
+// UNNEEDED int bus_endpoint_new(BusEndpoint **ep);
+void bus_endpoint_free(BusEndpoint *endpoint);
+
+// UNNEEDED int bus_endpoint_add_policy(BusEndpoint *ep, const char *name, BusPolicyAccess access);
+
+int bus_kernel_set_endpoint_policy(int fd, uid_t uid, BusEndpoint *ep);
diff --git a/src/login/logind.c b/src/login/logind.c
index 73ba53d5b..575bcee5b 100644
--- a/src/login/logind.c
+++ b/src/login/logind.c
@@ -34,6 +34,7 @@
#include "udev-util.h"
#include "formats-util.h"
#include "label.h"
+#include "label.h"
static void manager_free(Manager *m);
@@ -1123,8 +1124,8 @@ static int manager_run(Manager *m) {
static int manager_parse_config_file(Manager *m) {
assert(m);
- return config_parse_many("/etc/systemd/logind.conf",
- CONF_DIRS_NULSTR("systemd/logind.conf"),
+ return config_parse_many("/etc/elogind/elogind.conf",
+ CONF_DIRS_NULSTR("elogind/elogind.conf"),
"Login\0",
config_item_perf_lookup, logind_gperf_lookup,
false, m);