summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-10-03 10:41:51 +0200
committerSven Eden <yamakuzure@gmx.net>2017-11-23 08:11:42 +0100
commit3344b839df8fe2dd2b4a4f470225e4c407cf2faa (patch)
treea64c86cfe6adc5718143f5604fef893cfd94a865 /src/test/meson.build
parent7d729de3a70bc7a7fef69f5cea03fcbf835e118a (diff)
build-sys: use #if Y instead of #ifdef Y everywhere
The advantage is that is the name is mispellt, cpp will warn us. $ git grep -Ee "conf.set\('(HAVE|ENABLE)_" -l|xargs sed -r -i "s/conf.set\('(HAVE|ENABLE)_/conf.set10('\1_/" $ git grep -Ee '#ifn?def (HAVE|ENABLE)' -l|xargs sed -r -i 's/#ifdef (HAVE|ENABLE)/#if \1/; s/#ifndef (HAVE|ENABLE)/#if ! \1/;' $ git grep -Ee 'if.*defined\(HAVE' -l|xargs sed -i -r 's/defined\((HAVE_[A-Z0-9_]*)\)/\1/g' $ git grep -Ee 'if.*defined\(ENABLE' -l|xargs sed -i -r 's/defined\((ENABLE_[A-Z0-9_]*)\)/\1/g' + manual changes to meson.build squash! build-sys: use #if Y instead of #ifdef Y everywhere v2: - fix incorrect setting of HAVE_LIBIDN2
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index c811dd675..a923d6144 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -35,10 +35,10 @@ test_libelogind_sym_c = custom_target(
# output : 'test-libudev-sym.c',
# command : [generate_sym_test_py, '@INPUT0@', '@INPUT1@'],
# capture : true)
-#
-# test_dlopen_c = files('test-dlopen.c')
#endif // 0
+test_dlopen_c = files('test-dlopen.c')
+
############################################################
tests += [
@@ -365,6 +365,7 @@ tests += [
[libbasic],
[]],
+#if 0 /// UNNEEDED in elogind
# [['src/test/test-bpf.c',
# 'src/test/test-helper.c'],
# [libcore,
@@ -375,6 +376,7 @@ tests += [
# libseccomp,
# libselinux,
# libblkid]],
+#endif // 0
[['src/test/test-hashmap.c',
'src/test/test-hashmap-plain.c',