summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-03-13 08:17:29 +0100
committerSven Eden <yamakuzure@gmx.net>2018-03-13 08:18:56 +0100
commitaaae10b1838c7cb84608fe905e6360b9b8544e1b (patch)
treee78259842861d6315f80afe8065639a43f9513ca /src
parentb3fbcb51172f39bd89e35b408fb774547d3800ec (diff)
Prep v236: Apply missing upstream updates to the build system
Diffstat (limited to 'src')
-rw-r--r--src/basic/meson.build22
-rw-r--r--src/core/meson.build33
-rw-r--r--src/libelogind/meson.build17
-rw-r--r--src/login/meson.build28
-rw-r--r--src/shared/meson.build21
-rw-r--r--src/systemd/meson.build17
-rw-r--r--src/test/meson.build31
7 files changed, 149 insertions, 20 deletions
diff --git a/src/basic/meson.build b/src/basic/meson.build
index 987ca0a97..88000bfb3 100644
--- a/src/basic/meson.build
+++ b/src/basic/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
#if 0 /// elogind has a shorter list
# basic_sources_plain = files('''
# MurmurHash2.c
@@ -45,6 +62,8 @@
# copy.h
# cpu-set-util.c
# cpu-set-util.h
+# crypt-util.c
+# crypt-util.h
# def.h
# device-nodes.c
# device-nodes.h
@@ -114,6 +133,7 @@
# mkdir-label.c
# mkdir.c
# mkdir.h
+# module-util.h
# mount-util.c
# mount-util.h
# nss-util.h
@@ -184,6 +204,8 @@
# unaligned.h
# unit-name.c
# unit-name.h
+# unit-def.c
+# unit-def.h
# user-util.c
# user-util.h
# utf8.c
diff --git a/src/core/meson.build b/src/core/meson.build
index 8da7c391a..ce8c0f647 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
#if 0 /// elogind has only two of the parts here in it...
# libcore_la_sources = '''
# audit-fd.c
@@ -207,26 +224,16 @@ libcore_la_sources = files('''
# output : 'org.freedesktop.systemd1.policy.in',
# configuration : substs)
#
-# custom_target(
+# i18n.merge_file(
# 'org.freedesktop.systemd1.policy',
# input : policy_in,
# output : 'org.freedesktop.systemd1.policy',
-# command : intltool_command,
+# po_dir : po_dir,
+# data_dirs : po_dir,
# install : install_polkit,
# install_dir : polkitpolicydir)
#endif // 0
-# TODO: this might work with meson from git, see
-# https://github.com/mesonbuild/meson/issues/1441#issuecomment-283585493
-#
-# i18n.merge_file(
-# 'org.freedesktop.systemd1.policy',
-# po_dir : po_dir,
-# input : policy_in,
-# output : 'org.freedesktop.systemd1.policy',
-# install : install_polkit,
-# install_dir : polkitpolicydir)
-
#if 0 /// totally UNNEEDED in elogind
# install_data('system.conf',
# 'user.conf',
diff --git a/src/libelogind/meson.build b/src/libelogind/meson.build
index 098a8a34b..d4306bba0 100644
--- a/src/libelogind/meson.build
+++ b/src/libelogind/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
sd_login_c = files('sd-login/sd-login.c')
#if 0 /// elogind has a shorter list, of course...
diff --git a/src/login/meson.build b/src/login/meson.build
index b46576d68..401741e6b 100644
--- a/src/login/meson.build
+++ b/src/login/meson.build
@@ -1,4 +1,22 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
#if 0 /// rename to elogind
+#
# systemd_logind_sources = files('''
# logind.c
# logind.h
@@ -105,11 +123,12 @@ loginctl_sources += files('''
# install_data('org.freedesktop.login1.service',
# install_dir : dbussystemservicedir)
#
-# custom_target(
+# i18n.merge_file(
# 'org.freedesktop.login1.policy',
# input : 'org.freedesktop.login1.policy.in',
# output : 'org.freedesktop.login1.policy',
-# command : intltool_command,
+# po_dir : po_dir,
+# data_dirs : po_dir,
# install : install_polkit,
# install_dir : polkitpolicydir)
#
@@ -156,11 +175,12 @@ logind_service = configure_file(
install_data(logind_service,
install_dir : dbussystemservicedir)
-custom_target(
+i18n.merge_file(
'org.freedesktop.login1.policy',
input : 'org.freedesktop.login1.policy.in',
output : 'org.freedesktop.login1.policy',
- command : intltool_command,
+ po_dir : po_dir,
+ data_dirs : po_dir,
install : install_polkit,
install_dir : polkitpolicydir)
diff --git a/src/shared/meson.build b/src/shared/meson.build
index bb4024888..ad134c143 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
#if 0 /// elogind has a much shorter list
# shared_sources = '''
# acl-util.h
@@ -11,6 +28,8 @@
# base-filesystem.h
# boot-timestamps.c
# boot-timestamps.h
+# bootspec.c
+# bootspec.h
# bus-unit-util.c
# bus-unit-util.h
# bus-util.c
@@ -89,6 +108,8 @@
# sysctl-util.h
# tests.c
# tests.h
+# tomoyo-util.c
+# tomoyo-util.h
# udev-util.h
# udev-util.c
# uid-range.c
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index 8499f16c4..7d6398714 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
#if 0 /// No systemd-journal in elogind ...
# _systemd_headers = '''
# sd-bus.h
diff --git a/src/test/meson.build b/src/test/meson.build
index 89d742a80..6daef1f20 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
awkscript = 'test-hashmap-ordered.awk'
test_hashmap_ordered_c = custom_target(
'test-hashmap-ordered.c',
@@ -41,6 +58,12 @@ test_dlopen_c = files('test-dlopen.c')
############################################################
+#if 0 /// UNNEEDED by elogind
+# test_elogind_tmpfiles_py = find_program('test-elogind-tmpfiles.py')
+#endif // 0
+
+############################################################
+
tests += [
#if 0 /// UNNEEDED in elogind
# [['src/test/test-device-nodes.c'],
@@ -145,7 +168,8 @@ tests += [
#
# [['src/test/test-async.c'],
# [],
-# []],
+# [],
+# '', 'timeout=120'],
#endif // 0
[['src/test/test-locale-util.c'],
@@ -440,7 +464,7 @@ tests += [
# [],
# []],
#
-# [['src/test/test-time.c'],
+# [['src/test/test-time-util.c'],
# [],
# []],
#
@@ -702,7 +726,8 @@ tests += [
# libshared],
# [threads,
# libxz,
-# liblz4]],
+# liblz4],
+# '', 'timeout=360'],
#
# [['src/journal/test-journal-stream.c'],
# [libjournal_core,