summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorKylie McClain <kylie@somas.is>2018-06-07 00:23:07 -0400
committerSven Eden <yamakuzure@gmx.net>2018-06-08 15:33:05 +0200
commit7874bff7a506ee2b442e294f81e9d06dba739e9e (patch)
tree5d78b4e28d87b408de64918fc87048c2461e202a /tools
parent1b6bf41314f8a9df733d154b856b721736fe9bcd (diff)
meson.build: remove unnecessary `ln --relative` check
`ln --relative` is used by tools/meson-make-symlink.sh, which is never once ran during the build process for elogind. additionally, it incurrs a dependency on GNU coreutils (or any other `ln` that has the non-standard `--relative` extension), so there's no real need to check for it.
Diffstat (limited to 'tools')
-rwxr-xr-xtools/meson-make-symlink.sh12
1 files changed, 0 insertions, 12 deletions
diff --git a/tools/meson-make-symlink.sh b/tools/meson-make-symlink.sh
deleted file mode 100755
index 501cd43d4..000000000
--- a/tools/meson-make-symlink.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-set -eu
-
-# this is needed mostly because $DESTDIR is provided as a variable,
-# and we need to create the target directory...
-
-mkdir -vp "$(dirname "${DESTDIR:-}$2")"
-if [ "$(dirname $1)" = . ]; then
- ln -vfs -T "$1" "${DESTDIR:-}$2"
-else
- ln -vfs -T --relative "${DESTDIR:-}$1" "${DESTDIR:-}$2"
-fi