summaryrefslogtreecommitdiff
path: root/units/fedora
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-05-17 01:34:36 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-17 01:39:58 +0200
commit5e6afdd3d359fc42de7ac432243e98673577e81f (patch)
tree5119a863daffe744e6cfc40a224ed90ba49a4344 /units/fedora
parentf0b02ca2afa806efb73b43a81204ff21c4c65446 (diff)
units: add distribution-specific units
Diffstat (limited to 'units/fedora')
l---------units/fedora/Makefile1
-rw-r--r--units/fedora/halt.service29
-rw-r--r--units/fedora/killall.service25
-rw-r--r--units/fedora/poweroff.service28
-rw-r--r--units/fedora/prefdm.service27
-rw-r--r--units/fedora/rc-local.service31
-rw-r--r--units/fedora/reboot.service28
-rw-r--r--units/fedora/sysinit.service26
8 files changed, 195 insertions, 0 deletions
diff --git a/units/fedora/Makefile b/units/fedora/Makefile
new file mode 120000
index 000000000..50be21181
--- /dev/null
+++ b/units/fedora/Makefile
@@ -0,0 +1 @@
+../../src/Makefile \ No newline at end of file
diff --git a/units/fedora/halt.service b/units/fedora/halt.service
new file mode 100644
index 000000000..372b7e6f5
--- /dev/null
+++ b/units/fedora/halt.service
@@ -0,0 +1,29 @@
+# This file is part of systemd.
+#
+# Copyright 2010 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=Halt
+Requires=shutdown.target killall.service
+After=shutdown.target killall.service
+
+[Service]
+Type=finish
+Environment=INIT_HALT=HALT
+Environment=RUNLEVEL=0
+ExecStart=/etc/init.d/halt start
diff --git a/units/fedora/killall.service b/units/fedora/killall.service
new file mode 100644
index 000000000..1a6d47f39
--- /dev/null
+++ b/units/fedora/killall.service
@@ -0,0 +1,25 @@
+# This file is part of systemd.
+#
+# Copyright 2010 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=Kill All Processes
+
+[Service]
+Type=finish
+ExecStart=/etc/init.d/killall start
diff --git a/units/fedora/poweroff.service b/units/fedora/poweroff.service
new file mode 100644
index 000000000..82b9fac15
--- /dev/null
+++ b/units/fedora/poweroff.service
@@ -0,0 +1,28 @@
+# This file is part of systemd.
+#
+# Copyright 2010 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=Power-Off
+Requires=shutdown.target killall.service
+After=shutdown.target killall.service
+
+[Service]
+Type=finish
+Environment=RUNLEVEL=0
+ExecStart=/etc/init.d/halt start
diff --git a/units/fedora/prefdm.service b/units/fedora/prefdm.service
new file mode 100644
index 000000000..6ee35031d
--- /dev/null
+++ b/units/fedora/prefdm.service
@@ -0,0 +1,27 @@
+# This file is part of systemd.
+#
+# Copyright 2010 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=Display Manager
+Before=graphical.target
+After=basic.target syslog.target messagebus.service haldaemon.service
+
+[Service]
+ExecStart=/etc/X11/prefdm -nodaemon
+Type=simple
diff --git a/units/fedora/rc-local.service b/units/fedora/rc-local.service
new file mode 100644
index 000000000..b3ece1ed1
--- /dev/null
+++ b/units/fedora/rc-local.service
@@ -0,0 +1,31 @@
+# This file is part of systemd.
+#
+# Copyright 2010 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=/etc/rc.local Compatibility
+Requires=basic.target
+
+# The rcN.d symlink uses the name "local" while the script itself is
+# called "rc.local", hence carry both names here.
+Names=rc-local.service local.service
+
+[Service]
+ExecStart=/etc/rc.local start
+Type=simple
+SysVStartPriority=99
diff --git a/units/fedora/reboot.service b/units/fedora/reboot.service
new file mode 100644
index 000000000..45a293497
--- /dev/null
+++ b/units/fedora/reboot.service
@@ -0,0 +1,28 @@
+# This file is part of systemd.
+#
+# Copyright 2010 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=Reboot
+Requires=shutdown.target killall.service
+After=shutdown.target killall.service
+
+[Service]
+Type=finish
+Environment=RUNLEVEL=6
+ExecStart=/etc/init.d/reboot start
diff --git a/units/fedora/sysinit.service b/units/fedora/sysinit.service
new file mode 100644
index 000000000..fc7145300
--- /dev/null
+++ b/units/fedora/sysinit.service
@@ -0,0 +1,26 @@
+# This file is part of systemd.
+#
+# Copyright 2010 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=System Initialization
+Before=local-fs.target remote-fs.target swap.target sockets.target
+
+[Service]
+ExecStart=/etc/rc.d/rc.sysinit
+Type=finish