summaryrefslogtreecommitdiff
path: root/units
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-01-04 21:48:47 +0100
committerLennart Poettering <lennart@poettering.net>2013-01-04 23:26:20 +0100
commitb1c4ca25bf58e1925012d1dcdd83d61cecbf87fb (patch)
tree564526d2532f87ea2b90d974b87e0b5c4ce6619d /units
parent46a2911bf2780f616396df5671dd901cc7cb54fd (diff)
build-sys: make rc-local support part of SYSV compat
This also drops automatic selection of the rc local scripts based on the local distro. Distributions now should specify the paths of the rc-local and halt-local scripts on the configure command line.
Diffstat (limited to 'units')
-rw-r--r--units/.gitignore2
l---------units/fedora/Makefile1
-rw-r--r--units/halt-local.service.in (renamed from units/fedora/halt-local.service)6
-rw-r--r--units/rc-local.service.in (renamed from units/fedora/rc-local.service)7
-rw-r--r--units/suse/halt-local.service20
-rw-r--r--units/suse/rc-local.service19
6 files changed, 9 insertions, 46 deletions
diff --git a/units/.gitignore b/units/.gitignore
index 63c7ba06b..5e86d3011 100644
--- a/units/.gitignore
+++ b/units/.gitignore
@@ -1,3 +1,5 @@
+/halt-local.service
+/rc-local.service
/systemd-hybrid-sleep.service
/systemd-journal-gatewayd.service
/systemd-journal-flush.service
diff --git a/units/fedora/Makefile b/units/fedora/Makefile
deleted file mode 120000
index 50be21181..000000000
--- a/units/fedora/Makefile
+++ /dev/null
@@ -1 +0,0 @@
-../../src/Makefile \ No newline at end of file
diff --git a/units/fedora/halt-local.service b/units/halt-local.service.in
index a0a3a292e..c8be8965a 100644
--- a/units/fedora/halt-local.service
+++ b/units/halt-local.service.in
@@ -6,15 +6,15 @@
# (at your option) any later version.
[Unit]
-Description=/sbin/halt.local Compatibility
-ConditionFileIsExecutable=/sbin/halt.local
+Description=@RC_LOCAL_SCRIPT_PATH_STOP@ Compatibility
+ConditionFileIsExecutable=@RC_LOCAL_SCRIPT_PATH_STOP@
DefaultDependencies=no
After=shutdown.target
Before=final.target
[Service]
Type=oneshot
-ExecStart=/sbin/halt.local
+ExecStart=@RC_LOCAL_SCRIPT_PATH_STOP@
TimeoutSec=0
StandardOutput=tty
RemainAfterExit=yes
diff --git a/units/fedora/rc-local.service b/units/rc-local.service.in
index 3b3bda9f6..97d44a7a2 100644
--- a/units/fedora/rc-local.service
+++ b/units/rc-local.service.in
@@ -6,14 +6,15 @@
# (at your option) any later version.
# This unit gets pulled automatically into multi-user.target by
-# systemd-rc-local-generator if /etc/rc.d/rc.local is executable.
+# systemd-rc-local-generator if @RC_LOCAL_SCRIPT_PATH_START@ is executable.
[Unit]
-Description=/etc/rc.d/rc.local Compatibility
+Description=@RC_LOCAL_SCRIPT_PATH_START@ Compatibility
+ConditionFileIsExecutable=@RC_LOCAL_SCRIPT_PATH_START@
After=network.target
[Service]
Type=forking
-ExecStart=/etc/rc.d/rc.local start
+ExecStart=@RC_LOCAL_SCRIPT_PATH_START@ start
TimeoutSec=0
RemainAfterExit=yes
SysVStartPriority=99
diff --git a/units/suse/halt-local.service b/units/suse/halt-local.service
deleted file mode 100644
index 3a3a7930e..000000000
--- a/units/suse/halt-local.service
+++ /dev/null
@@ -1,20 +0,0 @@
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-
-[Unit]
-Description=/etc/init.d/halt.local Compatibility
-ConditionFileIsExecutable=/etc/init.d/halt.local
-DefaultDependencies=no
-After=shutdown.target
-Before=final.target
-
-[Service]
-Type=oneshot
-ExecStart=/etc/init.d/halt.local
-TimeoutSec=0
-StandardOutput=tty
-RemainAfterExit=yes
diff --git a/units/suse/rc-local.service b/units/suse/rc-local.service
deleted file mode 100644
index 0fd70e0fc..000000000
--- a/units/suse/rc-local.service
+++ /dev/null
@@ -1,19 +0,0 @@
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-
-# This unit gets pulled automatically into multi-user.target by
-# systemd-rc-local-generator if /etc/init.d/boot.local is executable.
-[Unit]
-Description=/etc/init.d/boot.local Compatibility
-After=network.target
-
-[Service]
-Type=oneshot
-ExecStart=/etc/init.d/boot.local
-TimeoutSec=0
-RemainAfterExit=yes
-SysVStartPriority=99