summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am8
-rw-r--r--man/systemd-hostnamed.service.xml82
-rw-r--r--man/systemd-localed.service.xml4
-rw-r--r--units/systemd-hostnamed.service.in3
4 files changed, 93 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 5c7405373..054481426 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2595,6 +2595,14 @@ hostnamed-install-data-hook:
INSTALL_DATA_HOOKS += \
hostnamed-install-data-hook
+MANPAGES += \
+ man/systemd-hostnamed.service.8
+
+MANPAGES_ALIAS += \
+ man/systemd-hostnamed.8
+
+man/systemd-hostnamed.8: man/systemd-hostnamed.service.8
+
EXTRA_DIST += \
units/systemd-hostnamed.service.in
endif
diff --git a/man/systemd-hostnamed.service.xml b/man/systemd-hostnamed.service.xml
new file mode 100644
index 000000000..13b3de02f
--- /dev/null
+++ b/man/systemd-hostnamed.service.xml
@@ -0,0 +1,82 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2012 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="systemd-hostnamed.service">
+
+ <refentryinfo>
+ <title>systemd-hostnamed</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>systemd-hostnamed</refentrytitle>
+ <manvolnum>8</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>systemd-hostnamed.service</refname>
+ <refname>systemd-hostnamed</refname>
+ <refpurpose>systemd Hostname Bus Mechanism</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <para><filename>systemd-hostnamed.service</filename></para>
+ <para><filename>/usr/lib/systemd/systemd-hostnamed</filename></para>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><filename>systemd-hostnamed</filename> is a system
+ service that may be used as mechanism to change the
+ system hostname. <filename>systemd-hostnamed</filename> is
+ automatically activated on request and terminates
+ itself when it is unused.</para>
+
+ <para>See the <ulink
+ url="http://www.freedesktop.org/wiki/Software/systemd/hostnamed">
+ developer documentation</ulink> for information about
+ the APIs <filename>systemd-hostnamed</filename>
+ provides.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+ <para>
+ <citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>hostname</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sethostname</refentrytitle><manvolnum>2</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>machine-info</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
+ </para>
+ </refsect1>
+
+</refentry>
diff --git a/man/systemd-localed.service.xml b/man/systemd-localed.service.xml
index bdc2a0813..df746fc88 100644
--- a/man/systemd-localed.service.xml
+++ b/man/systemd-localed.service.xml
@@ -45,7 +45,7 @@
<refnamediv>
<refname>systemd-localed.service</refname>
<refname>systemd-localed</refname>
- <refpurpose>systemd Time and Date Bus Mechanism</refpurpose>
+ <refpurpose>systemd Locale Bus Mechanism</refpurpose>
</refnamediv>
<refsynopsisdiv>
@@ -60,7 +60,7 @@
service that may be used as mechanism to change the
system locale settings, as well as the console key
mapping and default X11 key
- mapping. <filename>systemd-timedated</filename> is
+ mapping. <filename>systemd-localed</filename> is
automatically activated on request and terminates
itself when it is unused.</para>
diff --git a/units/systemd-hostnamed.service.in b/units/systemd-hostnamed.service.in
index d7fd1940f..be22a3ad0 100644
--- a/units/systemd-hostnamed.service.in
+++ b/units/systemd-hostnamed.service.in
@@ -7,8 +7,7 @@
[Unit]
Description=Hostname Service
-Documentation=man:hostname(5)
-Documentation=man:machine-info(5)
+Documentation=man:systemd-hostnamed.service(8) man:hostname(5) man:machine-info(5)
Documentation=http://www.freedesktop.org/wiki/Software/systemd/hostnamed
[Service]