summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am5
-rw-r--r--man/systemd-detect-virt.xml151
2 files changed, 154 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5bba4f990..2c047a0f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -205,7 +205,8 @@ bin_PROGRAMS = \
systemd-cgls \
systemd-cgtop \
systemd-stdio-bridge \
- systemd-nspawn
+ systemd-nspawn \
+ systemd-detect-virt
dist_bin_SCRIPTS = \
src/systemd-analyze
@@ -223,7 +224,6 @@ rootlibexec_PROGRAMS = \
systemd-fsck \
systemd-timestamp \
systemd-ac-power \
- systemd-detect-virt \
systemd-sysctl
systemgenerator_PROGRAMS = \
@@ -484,6 +484,7 @@ MANPAGES = \
man/systemd-ask-password.1 \
man/systemd-cat.1 \
man/systemd-machine-id-setup.1 \
+ man/systemd-detect-virt.1 \
man/journald.conf.5 \
man/journalctl.1
diff --git a/man/systemd-detect-virt.xml b/man/systemd-detect-virt.xml
new file mode 100644
index 000000000..75cc714f5
--- /dev/null
+++ b/man/systemd-detect-virt.xml
@@ -0,0 +1,151 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="systemd-detect-virt">
+
+ <refentryinfo>
+ <title>systemd-detect-virt</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>systemd-detect-virt</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>systemd-detect-virt</refname>
+ <refpurpose>Detect execution in a virtualized environment</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>systemd-detect-virt <arg choice="opt" rep="repeat">OPTIONS</arg></command>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><command>systemd-detect-virt</command> detects
+ execution in a virtualized environment. It identifies
+ the virtualization technology and can distuingish full
+ VM virtualization from container
+ virtualization.</para>
+
+ <para>When executed without <option>--quiet</option>
+ will print a short identifier for the detected
+ virtualization technology. The following technologies
+ are currently identified: <varname>qemu</varname>,
+ <varname>kvm</varname>, <varname>vmware</varname>,
+ <varname>microsoft</varname>,
+ <varname>oracle</varname>, <varname>xen</varname>,
+ <varname>bochs</varname>, <varname>chroot</varname>,
+ <varname>openvz</varname>, <varname>lxc</varname>,
+ <varname>lxc-libvirt</varname>,
+ <varname>systemd-nspawn</varname>.</para>
+
+ <para>If multiple virtualization solutions are used
+ only the "innermost" is detected and identified. That
+ means if both VM virtualization and container
+ virtualization are used in conjunction only the latter
+ will be identified (unless <option>--vm</option> is
+ passed).</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Options</title>
+
+ <para>The following options are understood:</para>
+
+ <variablelist>
+ <varlistentry>
+ <term><option>-h</option></term>
+ <term><option>--help</option></term>
+
+ <listitem><para>Prints a short help
+ text and exits.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term><option>--version</option></term>
+
+ <listitem><para>Prints a short version
+ string and exits.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term><option>-c</option></term>
+ <term><option>--container</option></term>
+
+ <listitem><para>Only detects container
+ virtualization (i.e. shared kernel
+ virtualization).</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term><option>-v</option></term>
+ <term><option>--vm</option></term>
+
+ <listitem><para>Only detects VM
+ virtualization (i.e. full hardware
+ virtualization).</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term><option>-q</option></term>
+ <term><option>--quiet</option></term>
+
+ <listitem><para>Suppress output of the
+ virtualization technology
+ identifier.</para></listitem>
+ </varlistentry>
+
+ </variablelist>
+
+ </refsect1>
+
+ <refsect1>
+ <title>Exit status</title>
+
+ <para>If a virtualization technology is detected 0 is
+ returned, a non-zero code otherwise.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+ <para>
+ <citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>