summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c226dfaed..1356ae996 100644
--- a/meson.build
+++ b/meson.build
@@ -369,7 +369,6 @@ endif
# '-Wold-style-definition',
# '-Wpointer-arith',
# '-Winit-self',
-# '-Wdeclaration-after-statement',
# '-Wfloat-equal',
# '-Wsuggest-attribute=noreturn',
# '-Werror=missing-prototypes',
@@ -435,7 +434,7 @@ endif
add_project_arguments(cc.get_supported_arguments(possible_cc_flags), language : 'c')
# "negative" arguments: gcc on purpose does not return an error for "-Wno-"
-# arguments, just emits a warnings. So test for the "positive" version instead.
+# arguments, just emits a warning. So test for the "positive" version instead.
foreach arg : ['unused-parameter',
'missing-field-initializers',
'unused-result',
@@ -1928,6 +1927,7 @@ executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
+executable('elogind-user-runtime-dir',
user_runtime_dir_sources,
include_directories : includes,
link_with : [libshared, liblogind_core],