summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 242ff92fa..b40500c55 100644
--- a/meson.build
+++ b/meson.build
@@ -444,8 +444,7 @@ if cc.get_id() == 'clang'
foreach arg : ['-Wno-typedef-redefinition',
'-Wno-gnu-variable-sized-type-not-at-end',
]
- if cc.has_argument(arg,
- name : '@0@ is supported'.format(arg))
+ if cc.has_argument(arg)
add_project_arguments(arg, language : 'c')
endif
endforeach
@@ -472,8 +471,7 @@ endforeach
if get_option('buildtype') != 'debug'
foreach arg : ['-ffunction-sections',
'-fdata-sections']
- if cc.has_argument(arg,
- name : '@0@ is supported'.format(arg))
+ if cc.has_argument(arg)
add_project_arguments(arg, language : 'c')
endif
endforeach
@@ -1918,6 +1916,7 @@ exe = executable('elogind-inhibit',
install_dir : rootbindir)
public_programs += [exe]
executable('elogind-user-runtime-dir',
+executable('elogind-user-runtime-dir',
user_runtime_dir_sources,
include_directories : includes,
link_with : [libshared, liblogind_core],