summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile.am15
-rw-r--r--fixme6
-rw-r--r--src/hashmap.c9
-rw-r--r--src/hashmap.h1
-rw-r--r--src/mount-setup.c4
-rw-r--r--src/remount-api-vfs.c147
-rw-r--r--src/set.c7
-rw-r--r--units/.gitignore1
-rw-r--r--units/systemd-modules-load.service.in1
-rw-r--r--units/systemd-remount-api-vfs.service.in20
11 files changed, 199 insertions, 13 deletions
diff --git a/.gitignore b/.gitignore
index 99b533854..42d9c8c67 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+systemd-remount-api-vfs
test-hostname
systemd-modules-load
systemd-auto-console-getty
diff --git a/Makefile.am b/Makefile.am
index 1a7142158..6266a0ee0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -74,7 +74,8 @@ rootlibexec_PROGRAMS = \
systemd-random-seed \
systemd-shutdownd \
systemd-auto-console-getty \
- systemd-modules-load
+ systemd-modules-load \
+ systemd-remount-api-vfs
noinst_PROGRAMS = \
test-engine \
@@ -175,6 +176,7 @@ nodist_systemunit_DATA = \
units/systemd-shutdownd.service \
units/systemd-auto-console-getty.service \
units/systemd-modules-load.service \
+ units/systemd-remount-api-vfs.service \
units/systemd-update-utmp-runlevel.service \
units/systemd-update-utmp-shutdown.service \
units/systemd-random-seed-save.service \
@@ -199,6 +201,7 @@ EXTRA_DIST = \
units/systemd-shutdownd.service.in \
units/systemd-auto-console-getty.service.in \
units/systemd-modules-load.service.in \
+ units/systemd-remount-api-vfs.service.in \
units/systemd-update-utmp-runlevel.service.in \
units/systemd-update-utmp-shutdown.service.in \
units/systemd-random-seed-save.service.in \
@@ -586,6 +589,16 @@ systemd_modules_load_CFLAGS = \
systemd_modules_load_LDADD = \
libsystemd-basic.la
+systemd_remount_api_vfs_SOURCES = \
+ src/remount-api-vfs.c \
+ src/mount-setup.c
+
+systemd_remount_api_vfs_CFLAGS = \
+ $(AM_CFLAGS)
+
+systemd_remount_api_vfs_LDADD = \
+ libsystemd-basic.la
+
systemd_cgroups_agent_SOURCES = \
src/cgroups-agent.c \
src/dbus-common.c
diff --git a/fixme b/fixme
index b43a10213..2ff9a80ae 100644
--- a/fixme
+++ b/fixme
@@ -42,8 +42,6 @@
* selinux policy loading
-* place /etc/inittab with explaining blurb.
-
* fingerprint.target, wireless.target, gps.target
* set_put(), hashmap_put() return values checken. i.e. == 0 macht kein free()!
@@ -60,10 +58,10 @@
* bash completion a la gdbus
-* api mounts gegen fstab mergen und remounten
-
External:
+* place /etc/inittab with explaining blurb.
+
* procps, psmisc, sysvinit-tools, hostname → util-linux-ng
* nologin nach /var/run https://bugzilla.redhat.com/show_bug.cgi?id=624489
diff --git a/src/hashmap.c b/src/hashmap.c
index 6b6e909ba..51f00131f 100644
--- a/src/hashmap.c
+++ b/src/hashmap.c
@@ -173,6 +173,15 @@ void hashmap_free(Hashmap*h) {
free(h);
}
+void hashmap_free_free(Hashmap *h) {
+ void *p;
+
+ while ((p = hashmap_steal_first(h)))
+ free(p);
+
+ hashmap_free(h);
+}
+
void hashmap_clear(Hashmap *h) {
if (!h)
return;
diff --git a/src/hashmap.h b/src/hashmap.h
index 9ab66c51b..c48d6b31f 100644
--- a/src/hashmap.h
+++ b/src/hashmap.h
@@ -47,6 +47,7 @@ int trivial_compare_func(const void *a, const void *b);
Hashmap *hashmap_new(hash_func_t hash_func, compare_func_t compare_func);
void hashmap_free(Hashmap *h);
+void hashmap_free_free(Hashmap *h);
Hashmap *hashmap_copy(Hashmap *h);
int hashmap_ensure_allocated(Hashmap **h, hash_func_t hash_func, compare_func_t compare_func);
diff --git a/src/mount-setup.c b/src/mount-setup.c
index ecd9e181c..8b4d8c7f4 100644
--- a/src/mount-setup.c
+++ b/src/mount-setup.c
@@ -68,11 +68,11 @@ bool mount_point_is_api(const char *path) {
* should be ignored */
for (i = 0; i < ELEMENTSOF(mount_table); i ++)
- if (path_startswith(path, mount_table[i].where))
+ if (path_equal(path, mount_table[i].where))
return true;
for (i = 0; i < ELEMENTSOF(ignore_paths); i++)
- if (path_startswith(path, ignore_paths[i]))
+ if (path_equal(path, ignore_paths[i]))
return true;
return path_startswith(path, "/cgroup/");
diff --git a/src/remount-api-vfs.c b/src/remount-api-vfs.c
new file mode 100644
index 000000000..d51a584f2
--- /dev/null
+++ b/src/remount-api-vfs.c
@@ -0,0 +1,147 @@
+/*-*- Mode: C; c-basic-offset: 8; indent-tabs-mode: nil -*-*/
+
+/***
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+#include <unistd.h>
+#include <fcntl.h>
+#include <errno.h>
+#include <string.h>
+#include <sys/stat.h>
+#include <sys/wait.h>
+#include <mntent.h>
+
+#include "log.h"
+#include "util.h"
+#include "set.h"
+#include "mount-setup.h"
+
+/* Goes through /etc/fstab and remounts all API file systems, applying
+ * options that are in /etc/fstab that systemd might not have
+ * respected */
+
+int main(int argc, char *argv[]) {
+ int ret = 1;
+ FILE *f = NULL;
+ struct mntent* me;
+ Hashmap *pids = NULL;
+
+ if (argc > 1) {
+ log_error("This program takes no argument.");
+ return 1;
+ }
+
+ log_set_target(LOG_TARGET_SYSLOG_OR_KMSG);
+ log_parse_environment();
+ log_open();
+
+ if (!(f = setmntent("/etc/fstab", "r"))) {
+ log_error("Failed to open /etc/fstab: %m");
+ goto finish;
+ }
+
+ if (!(pids = hashmap_new(trivial_hash_func, trivial_compare_func))) {
+ log_error("Failed to allocate set");
+ goto finish;
+ }
+
+ ret = 0;
+
+ while ((me = getmntent(f))) {
+ pid_t pid;
+ int k;
+ char *s;
+
+ if (!mount_point_is_api(me->mnt_dir))
+ continue;
+
+ log_debug("Remounting %s", me->mnt_dir);
+
+ if ((pid = fork()) < 0) {
+ log_error("Failed to fork: %m");
+ ret = 1;
+ continue;
+ }
+
+ if (pid == 0) {
+ const char *arguments[5];
+ /* Child */
+
+ arguments[0] = "/bin/mount";
+ arguments[1] = me->mnt_dir;
+ arguments[2] = "-o";
+ arguments[3] = "remount";
+ arguments[4] = NULL;
+
+ execv("/bin/mount", (char **) arguments);
+
+ log_error("Failed to execute /bin/mount: %m");
+ _exit(1);
+ }
+
+ /* Parent */
+
+ s = strdup(me->mnt_dir);
+
+ if ((k = hashmap_put(pids, UINT_TO_PTR(pid), s)) < 0) {
+ log_error("Failed to add PID to set: %s", strerror(-k));
+ ret = 1;
+ continue;
+ }
+ }
+
+ while (!hashmap_isempty(pids)) {
+ siginfo_t si;
+ char *s;
+
+ zero(si);
+ if (waitid(P_ALL, 0, &si, WEXITED) < 0) {
+
+ if (errno == EINTR)
+ continue;
+
+ log_error("waitid() failed: %m");
+ ret = 1;
+ break;
+ }
+
+ if ((s = hashmap_remove(pids, UINT_TO_PTR(si.si_pid)))) {
+ if (!is_clean_exit(si.si_code, si.si_status)) {
+ if (si.si_code == CLD_EXITED)
+ log_error("/bin/mount for %s exited with exit status %i.", s, si.si_status);
+ else
+ log_error("/bin/mount for %s terminated by signal %s.", s, signal_to_string(si.si_status));
+
+ ret = 1;
+ }
+
+ free(s);
+ }
+ }
+
+finish:
+
+ if (pids)
+ hashmap_free_free(pids);
+
+ if (f)
+ endmntent(f);
+
+ return ret;
+}
diff --git a/src/set.c b/src/set.c
index 331d37e3d..097b9d3aa 100644
--- a/src/set.c
+++ b/src/set.c
@@ -38,12 +38,7 @@ void set_free(Set* s) {
}
void set_free_free(Set *s) {
- void *p;
-
- while ((p = set_steal_first(s)))
- free(p);
-
- set_free(s);
+ hashmap_free_free(MAKE_HASHMAP(s));
}
int set_ensure_allocated(Set **s, hash_func_t hash_func, compare_func_t compare_func) {
diff --git a/units/.gitignore b/units/.gitignore
index 23857d231..801e9d61e 100644
--- a/units/.gitignore
+++ b/units/.gitignore
@@ -1,4 +1,5 @@
systemd-modules-load.service
+systemd-remount-api-vfs.service
systemd-auto-console-getty.service
systemd-shutdownd.service
systemd-random-seed-load.service
diff --git a/units/systemd-modules-load.service.in b/units/systemd-modules-load.service.in
index 2390e02b3..7a94040fa 100644
--- a/units/systemd-modules-load.service.in
+++ b/units/systemd-modules-load.service.in
@@ -13,6 +13,7 @@ Before=shutdown.target
[Service]
Type=oneshot
+RemainAfterExit=yes
ExecStart=@rootlibexecdir@/systemd-modules-load
[Install]
diff --git a/units/systemd-remount-api-vfs.service.in b/units/systemd-remount-api-vfs.service.in
new file mode 100644
index 000000000..4aba863aa
--- /dev/null
+++ b/units/systemd-remount-api-vfs.service.in
@@ -0,0 +1,20 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Remount API VFS
+DefaultDependencies=no
+Conflicts=shutdown.target
+Before=shutdown.target local-fs.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=@rootlibexecdir@/systemd-remount-vfs
+
+[Install]
+WantedBy=sysinit.target