summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile-man.am14
-rw-r--r--Makefile.am6
-rw-r--r--configure.ac53
-rw-r--r--man/elogind.conf.xml3
-rw-r--r--man/loginctl.xml3
-rw-r--r--src/basic/build.h23
6 files changed, 8 insertions, 94 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 845f96a41..a0012b087 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -16,7 +16,9 @@ MANPAGES += \
man/sd_is_fifo.3 \
man/sd_machine_get_class.3 \
man/sd_notify.3 \
- man/sd_watchdog_enabled.3
+ man/sd_watchdog_enabled.3 \
+ man/elogind.conf.5 \
+ man/loginctl.1
MANPAGES_ALIAS += \
man/SD_BUS_ERROR_ACCESS_DENIED.3 \
man/SD_BUS_ERROR_ADDRESS_IN_USE.3 \
@@ -244,16 +246,6 @@ man/sd_pid_notifyf.html: man/sd_notify.html
$(html-alias)
-if ENABLE_LOGIND
-MANPAGES += \
- man/elogind.conf.5 \
- man/loginctl.1
-MANPAGES_ALIAS += \
- #
-
-
-endif
-
if HAVE_PAM
MANPAGES += \
man/pam_elogind.8 \
diff --git a/Makefile.am b/Makefile.am
index 0c89ac488..9eb834061 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -406,14 +406,12 @@ endif
libshared_la_CFLAGS = \
$(AM_CFLAGS) \
- $(ACL_CFLAGS) \
- $(SECCOMP_CFLAGS)
+ $(ACL_CFLAGS)
libshared_la_LIBADD = \
libelogind-internal.la \
$(UDEV_LIBS) \
- $(ACL_LIBS) \
- $(SECCOMP_LIBS)
+ $(ACL_LIBS)
gperf_txt_sources = \
src/basic/errno-list.txt
diff --git a/configure.ac b/configure.ac
index 7698bda8a..66a5e3e9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,33 +390,6 @@ fi
AM_CONDITIONAL(ENABLE_COVERAGE, [test "$have_coverage" = "yes"])
# ------------------------------------------------------------------------------
-have_blkid=no
-AC_ARG_ENABLE(blkid, AS_HELP_STRING([--disable-blkid], [disable blkid support]))
-if test "x$enable_blkid" != "xno"; then
- PKG_CHECK_MODULES(BLKID, [ blkid >= 2.24 ],
- [AC_DEFINE(HAVE_BLKID, 1, [Define if blkid is available]) have_blkid=yes], have_blkid=no)
- if test "x$have_blkid" = xno -a "x$enable_blkid" = xyes; then
- AC_MSG_ERROR([*** blkid support requested but libraries not found])
- fi
-fi
-AM_CONDITIONAL(HAVE_BLKID, [test "$have_blkid" = "yes"])
-
-# ------------------------------------------------------------------------------
-have_seccomp=no
-AC_ARG_ENABLE(seccomp, AS_HELP_STRING([--disable-seccomp], [Disable optional SECCOMP support]))
-if test "x$enable_seccomp" != "xno"; then
- PKG_CHECK_MODULES(SECCOMP, [libseccomp >= 1.0.0],
- [AC_DEFINE(HAVE_SECCOMP, 1, [Define if seccomp is available])
- have_seccomp=yes
- M4_DEFINES="$M4_DEFINES -DHAVE_SECCOMP"],
- [have_seccomp=no])
- if test "x$have_seccomp" = "xno" -a "x$enable_seccomp" = "xyes"; then
- AC_MSG_ERROR([*** seccomp support requested but libraries not found])
- fi
-fi
-AM_CONDITIONAL(HAVE_SECCOMP, [test "$have_seccomp" = "yes"])
-
-# ------------------------------------------------------------------------------
have_selinux=no
AC_ARG_ENABLE(selinux, AS_HELP_STRING([--disable-selinux], [Disable optional SELINUX support]))
if test "x$enable_selinux" != "xno"; then
@@ -431,20 +404,6 @@ if test "x$enable_selinux" != "xno"; then
fi
AM_CONDITIONAL(HAVE_SELINUX, [test "$have_selinux" = "yes"])
-have_apparmor=no
-AC_ARG_ENABLE(apparmor, AS_HELP_STRING([--disable-apparmor], [Disable optional AppArmor support]))
-if test "x$enable_apparmor" != "xno"; then
- PKG_CHECK_MODULES([APPARMOR], [libapparmor],
- [AC_DEFINE(HAVE_APPARMOR, 1, [Define if AppArmor is available])
- have_apparmor=yes
- M4_DEFINES="$M4_DEFINES -DHAVE_APPARMOR"],
- [have_apparmor=no])
- if test "x$have_apparmor" = xno -a "x$enable_apparmor" = xyes; then
- AC_MSG_ERROR([*** AppArmor support requested but libraries not found])
- fi
-fi
-AM_CONDITIONAL(HAVE_APPARMOR, [test "$have_apparmor" = "yes"])
-
# ------------------------------------------------------------------------------
AC_ARG_ENABLE([pam],
AS_HELP_STRING([--disable-pam],[Disable optional PAM support]),
@@ -556,15 +515,6 @@ fi
AM_CONDITIONAL([HAVE_SMACK], [test "x$have_smack" = "xyes"])
# ------------------------------------------------------------------------------
-have_logind=yes
-#AC_ARG_ENABLE(logind, AS_HELP_STRING([--disable-logind], [disable login daemon]))
-#if test "x$enable_logind" != "xno"; then
-# have_logind=yes
-#fi
-AM_CONDITIONAL(ENABLE_LOGIND, [test "$have_logind" = "yes"])
-AS_IF([test "$have_logind" = "yes"], [ AC_DEFINE(HAVE_LOGIND, [1], [Logind support available]) ])
-
-# ------------------------------------------------------------------------------
AC_ARG_WITH(system-uid-max,
AS_HELP_STRING([--with-system-uid-max=UID]
[Maximum UID for system users]),
@@ -752,13 +702,10 @@ AC_MSG_RESULT([
$PACKAGE_NAME $VERSION
PAM: ${have_pam}
- AppArmor: ${have_apparmor}
SELinux: ${have_selinux}
- SECCOMP: ${have_seccomp}
SMACK: ${have_smack}
ACL: ${have_acl}
polkit: ${have_polkit}
- blkid: ${have_blkid}
kdbus: ${have_kdbus}
Python: ${have_python}
man pages: ${have_manpages}
diff --git a/man/elogind.conf.xml b/man/elogind.conf.xml
index 268e6d822..ddb01ec4a 100644
--- a/man/elogind.conf.xml
+++ b/man/elogind.conf.xml
@@ -21,8 +21,7 @@
along with elogind; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="elogind.conf" conditional='ENABLE_LOGIND'
- xmlns:xi="http://www.w3.org/2001/XInclude">
+<refentry id="elogind.conf" xmlns:xi="http://www.w3.org/2001/XInclude">
<refentryinfo>
<title>elogind.conf</title>
<productname>elogind</productname>
diff --git a/man/loginctl.xml b/man/loginctl.xml
index 54a9a73d7..8a1ddb618 100644
--- a/man/loginctl.xml
+++ b/man/loginctl.xml
@@ -21,8 +21,7 @@
along with elogind; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="loginctl" conditional='ENABLE_LOGIND'
- xmlns:xi="http://www.w3.org/2001/XInclude">
+<refentry id="loginctl" xmlns:xi="http://www.w3.org/2001/XInclude">
<refentryinfo>
<title>loginctl</title>
diff --git a/src/basic/build.h b/src/basic/build.h
index 566bb74d8..c63b7cc01 100644
--- a/src/basic/build.h
+++ b/src/basic/build.h
@@ -33,12 +33,6 @@
#define _SELINUX_FEATURE_ "-SELINUX"
#endif
-#ifdef HAVE_APPARMOR
-#define _APPARMOR_FEATURE_ "+APPARMOR"
-#else
-#define _APPARMOR_FEATURE_ "-APPARMOR"
-#endif
-
#ifdef HAVE_SMACK
#define _SMACK_FEATURE_ "+SMACK"
#else
@@ -51,23 +45,8 @@
#define _ACL_FEATURE_ "-ACL"
#endif
-#ifdef HAVE_SECCOMP
-#define _SECCOMP_FEATURE_ "+SECCOMP"
-#else
-#define _SECCOMP_FEATURE_ "-SECCOMP"
-#endif
-
-#ifdef HAVE_BLKID
-#define _BLKID_FEATURE_ "+BLKID"
-#else
-#define _BLKID_FEATURE_ "-BLKID"
-#endif
-
#define SYSTEMD_FEATURES \
_PAM_FEATURE_ " " \
_SELINUX_FEATURE_ " " \
- _APPARMOR_FEATURE_ " " \
_SMACK_FEATURE_ " " \
- _ACL_FEATURE_ " " \
- _SECCOMP_FEATURE_ " " \
- _BLKID_FEATURE_ " "
+ _ACL_FEATURE_ " "