summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile-man.am5
-rw-r--r--TODO2
-rw-r--r--man/sd_pid_get_session.xml42
3 files changed, 37 insertions, 12 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index e74cceaad..a8d418fda 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -828,6 +828,7 @@ MANPAGES_ALIAS += \
man/sd_login_monitor_unref.3 \
man/sd_pid_get_machine_name.3 \
man/sd_pid_get_owner_uid.3 \
+ man/sd_pid_get_slice.3 \
man/sd_pid_get_unit.3 \
man/sd_pid_get_user_unit.3 \
man/sd_seat_can_multi_session.3 \
@@ -855,6 +856,7 @@ man/sd_login_monitor_get_timeout.3: man/sd_login_monitor_new.3
man/sd_login_monitor_unref.3: man/sd_login_monitor_new.3
man/sd_pid_get_machine_name.3: man/sd_pid_get_session.3
man/sd_pid_get_owner_uid.3: man/sd_pid_get_session.3
+man/sd_pid_get_slice.3: man/sd_pid_get_session.3
man/sd_pid_get_unit.3: man/sd_pid_get_session.3
man/sd_pid_get_user_unit.3: man/sd_pid_get_session.3
man/sd_seat_can_multi_session.3: man/sd_seat_get_active.3
@@ -904,6 +906,9 @@ man/sd_pid_get_machine_name.html: man/sd_pid_get_session.html
man/sd_pid_get_owner_uid.html: man/sd_pid_get_session.html
$(html-alias)
+man/sd_pid_get_slice.html: man/sd_pid_get_session.html
+ $(html-alias)
+
man/sd_pid_get_unit.html: man/sd_pid_get_session.html
$(html-alias)
diff --git a/TODO b/TODO
index 63b1280f0..d1d7140c8 100644
--- a/TODO
+++ b/TODO
@@ -46,7 +46,7 @@ CGroup Rework Completion:
* introduce high-level settings for RT budget, swappiness
* wiki: document new bus APIs of PID 1 (transient units, Reloading signal)
-* review: scope units, slice units, pid1, machinectl, libsystem-login, pam_system, systemctl commands
+* review: scope units, slice units, pid1, pam_system, systemctl commands
* Send SIGHUP and SIGTERM in session scopes
diff --git a/man/sd_pid_get_session.xml b/man/sd_pid_get_session.xml
index fd1ce4b87..ecd22f7bf 100644
--- a/man/sd_pid_get_session.xml
+++ b/man/sd_pid_get_session.xml
@@ -48,7 +48,10 @@
<refname>sd_pid_get_user_unit</refname>
<refname>sd_pid_get_owner_uid</refname>
<refname>sd_pid_get_machine_name</refname>
- <refpurpose>Determine session, service, owner of a session or container/VM of a specific PID</refpurpose>
+ <refname>sd_pid_get_slice</refname>
+ <refpurpose>Determine session, service, owner of a
+ session, container/VM or slice of a specific
+ PID</refpurpose>
</refnamediv>
<refsynopsisdiv>
@@ -84,6 +87,12 @@
<paramdef>pid_t <parameter>pid</parameter></paramdef>
<paramdef>char** <parameter>name</parameter></paramdef>
</funcprototype>
+
+ <funcprototype>
+ <funcdef>int <function>sd_pid_get_slice</function></funcdef>
+ <paramdef>pid_t <parameter>pid</parameter></paramdef>
+ <paramdef>char** <parameter>slice</parameter></paramdef>
+ </funcprototype>
</funcsynopsis>
</refsynopsisdiv>
@@ -138,11 +147,20 @@
and not being a shared process of a user this function
will fail.</para>
- <para><function>sd_pid_machine_name()</function> may
- be used to determine the name of the VM or container
- is a member of. The machine name is a short string,
- suitable for usage in file system paths. The returned
- string needs to be freed with the libc
+ <para><function>sd_pid_get_machine_name()</function>
+ may be used to determine the name of the VM or
+ container is a member of. The machine name is a short
+ string, suitable for usage in file system paths. The
+ returned string needs to be freed with the libc
+ <citerefentry><refentrytitle>free</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ call after use.</para>
+
+ <para><function>sd_pid_get_slice()</function> may be
+ used to determine the slice unit the process is a
+ member of. See
+ <citerefentry><refentrytitle>systemd.slice</refentrytitle><manvolnum>5</manvolnum></citerefentry>
+ for details about slices. The returned string needs to
+ be freed with the libc
<citerefentry><refentrytitle>free</refentrytitle><manvolnum>3</manvolnum></citerefentry>
call after use.</para>
@@ -165,10 +183,11 @@
<para>The <function>sd_pid_get_session()</function>,
<function>sd_pid_get_unit()</function>,
<function>sd_pid_get_user_unit()</function>,
- <function>sd_pid_get_owner_uid()</function> and
- <function>sd_pid_get_machine_name()</function>
- interfaces are available as shared library, which can
- be compiled and linked to with the
+ <function>sd_pid_get_owner_uid()</function>,
+ <function>sd_pid_get_machine_name()</function> and
+ <function>sd_pid_get_slice()</function> interfaces are
+ available as shared library, which can be compiled and
+ linked to with the
<constant>libsystemd-login</constant> <citerefentry><refentrytitle>pkg-config</refentrytitle><manvolnum>1</manvolnum></citerefentry>
file.</para>
@@ -186,7 +205,8 @@
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>sd-login</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
<citerefentry><refentrytitle>sd_session_is_active</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
- <citerefentry><refentrytitle>getsid</refentrytitle><manvolnum>2</manvolnum></citerefentry>
+ <citerefentry><refentrytitle>getsid</refentrytitle><manvolnum>2</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>systemd.slice</refentrytitle><manvolnum>5</manvolnum></citerefentry>
</para>
</refsect1>