summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am7
-rw-r--r--src/test/test-hashmap.c21
-rw-r--r--src/test/test-set.c47
3 files changed, 75 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7bb7f7591..9e087bd9f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1341,6 +1341,7 @@ tests += \
test-fileio \
test-time \
test-hashmap \
+ test-set \
test-list \
test-tables \
test-device-nodes \
@@ -1572,6 +1573,12 @@ test_hashmap_SOURCES = \
test_hashmap_LDADD = \
libsystemd-core.la
+test_set_SOURCES = \
+ src/test/test-set.c
+
+test_set_LDADD = \
+ libsystemd-core.la
+
test_xml_SOURCES = \
src/test/test-xml.c
diff --git a/src/test/test-hashmap.c b/src/test/test-hashmap.c
index d9863f8da..f4afbb8e9 100644
--- a/src/test/test-hashmap.c
+++ b/src/test/test-hashmap.c
@@ -507,6 +507,26 @@ static void test_hashmap_steal_first_key(void) {
assert_se(hashmap_isempty(m));
}
+static void test_hashmap_steal_first(void) {
+ _cleanup_hashmap_free_ Hashmap *m = NULL;
+ int seen[3] = {};
+ char *val;
+
+ m = hashmap_new(&string_hash_ops);
+ assert_se(m);
+
+ assert_se(hashmap_put(m, "key 1", (void*) "1") == 1);
+ assert_se(hashmap_put(m, "key 2", (void*) "22") == 1);
+ assert_se(hashmap_put(m, "key 3", (void*) "333") == 1);
+
+ while ((val = hashmap_steal_first(m)))
+ seen[strlen(val) - 1]++;
+
+ assert(seen[0] == 1 && seen[1] == 1 && seen[2] == 1);
+
+ assert_se(hashmap_isempty(m));
+}
+
static void test_hashmap_clear_free_free(void) {
_cleanup_hashmap_free_ Hashmap *m = NULL;
@@ -560,6 +580,7 @@ int main(int argc, const char *argv[]) {
test_hashmap_many();
test_hashmap_first_key();
test_hashmap_steal_first_key();
+ test_hashmap_steal_first();
test_hashmap_clear_free_free();
test_uint64_compare_func();
test_trivial_compare_func();
diff --git a/src/test/test-set.c b/src/test/test-set.c
new file mode 100644
index 000000000..060dba42d
--- /dev/null
+++ b/src/test/test-set.c
@@ -0,0 +1,47 @@
+/***
+ This file is part of systemd
+
+ Copyright 2014 Zbigniew Jędrzejewski-Szmek
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+#include "util.h"
+#include "set.h"
+
+static void test_set_steal_first(void) {
+ _cleanup_set_free_ Set *m = NULL;
+ int seen[3] = {};
+ char *val;
+
+ m = set_new(&string_hash_ops);
+ assert_se(m);
+
+ assert_se(set_put(m, (void*) "1") == 1);
+ assert_se(set_put(m, (void*) "22") == 1);
+ assert_se(set_put(m, (void*) "333") == 1);
+
+ while ((val = set_steal_first(m)))
+ seen[strlen(val) - 1]++;
+
+ assert(seen[0] == 1 && seen[1] == 1 && seen[2] == 1);
+
+ assert_se(set_isempty(m));
+}
+
+int main(int argc, const char *argv[]) {
+ test_set_steal_first();
+
+ return 0;
+}