summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am4
-rw-r--r--man/custom-html.xsl5
-rw-r--r--man/custom-man.xsl24
-rw-r--r--src/python-systemd/docs/layout.html2
4 files changed, 32 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 25e0ab430..cfcca7c88 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3680,9 +3680,9 @@ XSLTPROC_FLAGS = \
--nonet \
--stringparam man.output.quietly 1 \
--stringparam funcsynopsis.style ansi \
- --stringparam man.th.extra1.suppress 1 \
--stringparam man.authors.section.enabled 0 \
- --stringparam man.copyright.section.enabled 0
+ --stringparam man.copyright.section.enabled 0 \
+ --stringparam systemd.version $(VERSION)
XSLTPROC_PROCESS_MAN = \
$(AM_V_XSLT)$(MKDIR_P) $(dir $@) && \
diff --git a/man/custom-html.xsl b/man/custom-html.xsl
index c612baf4d..c4099b26b 100644
--- a/man/custom-html.xsl
+++ b/man/custom-html.xsl
@@ -65,6 +65,11 @@
</xsl:attribute>
<xsl:text>gudev </xsl:text>
</a>
+
+ <span style="float:right">
+ <xsl:text>systemd </xsl:text>
+ <xsl:value-of select="$systemd.version"/>
+ </span>
<hr/>
</xsl:template>
diff --git a/man/custom-man.xsl b/man/custom-man.xsl
index 4d9d08e00..753e5715e 100644
--- a/man/custom-man.xsl
+++ b/man/custom-man.xsl
@@ -28,4 +28,28 @@
<xsl:template name="top.comment" />
+<xsl:template name="TH.title.line">
+ <xsl:param name="title"/>
+ <xsl:param name="section"/>
+ <xsl:param name="extra1"/>
+ <xsl:param name="extra2"/>
+ <xsl:param name="extra3"/>
+
+ <xsl:call-template name="mark.subheading"/>
+ <xsl:text>.TH "</xsl:text>
+ <xsl:call-template name="string.upper">
+ <xsl:with-param name="string">
+ <xsl:value-of select="normalize-space($title)"/>
+ </xsl:with-param>
+ </xsl:call-template>
+ <xsl:text>" "</xsl:text>
+ <xsl:value-of select="normalize-space($section)"/>
+ <xsl:text>" "" "systemd </xsl:text>
+ <xsl:value-of select="$systemd.version"/>
+ <xsl:text>" "</xsl:text>
+ <xsl:value-of select="normalize-space($extra3)"/>
+ <xsl:text>"&#10;</xsl:text>
+ <xsl:call-template name="mark.subheading"/>
+</xsl:template>
+
</xsl:stylesheet>
diff --git a/src/python-systemd/docs/layout.html b/src/python-systemd/docs/layout.html
index 78989143e..be5ff980e 100644
--- a/src/python-systemd/docs/layout.html
+++ b/src/python-systemd/docs/layout.html
@@ -6,7 +6,7 @@
<a href="index.html">Python </a>·
<a href="../libudev/index.html">libudev </a>·
<a href="../libudev/index.html">gudev </a>
- <span style="float:right">systemd v. {{release}}</span>
+ <span style="float:right">systemd {{release}}</span>
<hr />
{% endblock %}