summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1aff72d3b..a87a02656 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,6 +224,13 @@ AS_IF([test "x$with_python" != "xno"], [
[AC_MSG_WARN([*** python support requires python-lxml module installed])])
])
])
+AS_IF([test "$have_python" != "yes"], [
+ AS_IF([test "$with_python" = "yes"],
+ [AC_MSG_ERROR([*** python support requested but python support not found])])
+ AS_IF([test "$with_python" != "no"],
+ [AC_MSG_WARN([*** python support not found, some documentation cannot be built])])
+])
+
AM_CONDITIONAL([HAVE_PYTHON], [test "x$have_python" = "xyes"])
AS_IF([test "x$PYTHON_BINARY" = "x"],
[AS_IF([test "x$have_python" = "xyes"],