summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am3
-rw-r--r--TODO4
-rw-r--r--units/sys-fs-fuse-connections.mount18
3 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e102a4ce..6f90e9c93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -362,6 +362,7 @@ dist_systemunit_DATA = \
units/sys-kernel-config.mount \
units/sys-kernel-debug.mount \
units/sys-kernel-security.mount \
+ units/sys-fs-fuse-connections.mount \
units/var-run.mount \
units/media.mount \
units/remount-rootfs.service \
@@ -1840,6 +1841,7 @@ endif
sys-kernel-config.mount \
sys-kernel-debug.mount \
sys-kernel-security.mount \
+ sys-fs-fuse-connections.mount \
systemd-vconsole-setup.service \
systemd-modules-load.service \
systemd-random-seed-load.service \
@@ -1853,6 +1855,7 @@ endif
$(LN_S) ../sys-kernel-config.mount sys-kernel-config.mount && \
$(LN_S) ../sys-kernel-debug.mount sys-kernel-debug.mount && \
$(LN_S) ../sys-kernel-security.mount sys-kernel-security.mount && \
+ $(LN_S) ../sys-fs-fuse-connections.mount sys-fs-fuse-connections.mount && \
$(LN_S) ../systemd-vconsole-setup.service systemd-vconsole-setup.service && \
$(LN_S) ../systemd-modules-load.service systemd-modules-load.service && \
$(LN_S) ../systemd-random-seed-load.service systemd-random-seed-load.service && \
diff --git a/TODO b/TODO
index 880123d68..2f6358c5a 100644
--- a/TODO
+++ b/TODO
@@ -17,6 +17,10 @@ Bugfixes:
Features:
+* add an option to make mounts private/shareable and so on, enable this for root by default
+
+* https://bugzilla.redhat.com/show_bug.cgi?id=727068
+
* for socket units don't inherit global stdout setting.
* internal restart counter for units (focus on auto-respawn)
diff --git a/units/sys-fs-fuse-connections.mount b/units/sys-fs-fuse-connections.mount
new file mode 100644
index 000000000..037471537
--- /dev/null
+++ b/units/sys-fs-fuse-connections.mount
@@ -0,0 +1,18 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=FUSE Control File System
+DefaultDependencies=no
+ConditionPathExists=/sys/fs/fuse/connections
+After=systemd-modules-load.service
+Before=sysinit.target
+
+[Mount]
+What=fusectl
+Where=/sys/fs/fuse/connections
+Type=fusectl