summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 18e934c38..bb6018f87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -672,7 +672,7 @@ AC_ARG_ENABLE([elfutils],
if test "x${have_elfutils}" != xno ; then
AC_CHECK_HEADERS(
[elfutils/libdwfl.h],
- [have_elfutils=yes],
+ [],
[if test "x$have_elfutils" = xyes ; then
AC_MSG_ERROR([*** ELFUTILS headers not found.])
fi])
@@ -680,11 +680,19 @@ if test "x${have_elfutils}" != xno ; then
AC_CHECK_LIB(
[dw],
[dwfl_begin],
- [have_elfutils=yes],
+ [],
[if test "x$have_elfutils" = xyes ; then
AC_MSG_ERROR([*** ELFUTILS libs not found.])
fi])
+ AC_CHECK_LIB(
+ [dw],
+ [dwfl_core_file_attach],
+ [have_elfutils=yes],
+ [if test "x$have_elfutils" = xyes ; then
+ AC_MSG_ERROR([*** ELFUTILS >= 158 is required.])
+ fi])
+
if test "x$have_elfutils" = xyes ; then
ELFUTILS_LIBS="-lelf -ldw"
AC_DEFINE(HAVE_ELFUTILS, 1, [ELFUTILS available])